Prevent Anonymous Users from creating pages

Is there a way that I can prevent an anonymous user from creating content?  I have the global permissions and space permissions set to only view.  However, when an anonymous user clicks the create button, they can create a page.  I would like to use my space as a Knowledgebase for my domain users, but I don't want them creating documents.

2 answers

This widget could not be displayed.

Yes, check the space permissions and make sure "anonymous" has no rights other than "read".

If you think you've done that, then we're going to need to see the permissions for a space where you think anonymous users can post.

I have double checked the permissions.  Screenshots below of the global permissions and the space permissions.GlobalPerms.PNGSpacePerms.PNG

Ok, looks good, can you show us all the permissions for the space (fuzz over any user names that might be in there, and parts of group names, if you have any security worries.  We only need the full list and an idea of the rules about who can do what, not which <identifiable person> can do what)

Thanks for looking at this.  Screengrab below of all space permissions.

SpacePerms2.PNG

Nope, you're absolutely right, anonymous access is not working correctly here.

Only one nagging doubt here before we yell for Atlassian.  When I say "anonymous", I mean "someone who has not logged in to your Confluence".

Is that the case?  You've got a session in a browser where you have clicked "log out", or fired it up and never logged in, and you can still create and edit pages?

Hey Nic-  Yes that's correct.   To verify this thoroughly,  i tested this by building in IE and viewing in chrome (also never logged into Confluence on Chrome).  Hosting Confluence on a VM and i was not logged in on the host, and was still able to create.  Do you know if anyone else has reported this? 

I have the same issue... any updates on it?

I found that the one job i work for has their production version at 6.4 and it works....IF I turn on anonymous access in the global. Then in the space, turn it on for view only, SAVE then turn it off. Save and then turn it back on.  To me it sounds like a bug, but it works right now, and i'm not going to touch it.

I ran into this 5-year old question trying to solve this same issue and deleting the Default Space (as suggested by the top answer) did indeed remove the "Create" button.

Hi all, I am on the same boat after upgrading to 6.10.0. Anonymous is on read only mode and everyday I get 1 created page.

This widget could not be displayed.

Spent more than half my day trying to solve this. Finally found the solution in an old 2013 post

Just delete the default space that gets created when you install Confluence. The Create button disappears magically for anonymous users! 

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Sep 17, 2018 in Confluence

Why start from scratch? Introducing four new templates for Confluence Cloud

Hi my Community friends!  For those who don't know me, I'm a product marketer on the Confluence Cloud team - nice to meet you! For those of you who do, you know that I've been all up in your Co...

569 views 7 6
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you