Pasting Content Causes the Page View to Jump

Operating System: Windows 10

Browser: Firefox 57

 

When editing a page, sometimes pasting content from the web into the page will cause the page view to jump randomly to a different section of the page.

 

Does anyone else have this problem?

3 answers

0 votes

Hi Jason,

Is there a certain type of content from a certain location that you've noticed causes this? I'd like to test it.

Regards,

Shannon

I'll keep an eye out for it and post back here with the results.

Thank you, Jason! I'll keep working on it and trying to replicate and let you know what I find.

Regards,
Shannon

Operating System: Windows 10

Browsers: Firefox 57

I can confirm this does not occur on Chrome 63 and Internet Explorer 11 exhibits a different more serious issue which I will describe in a new post.

https://community.atlassian.com/t5/Confluence-questions/Unable-to-Paste-Text-from-Notepad-to-Confluence-Using-IE11/qaq-p/700533#M93758

Steps

1. Create a Blank page in Confluence

2. Create and copy a large test data set so the vertical scrollbar is displayed, e.g. Lorum Ipsum

  a. https://www.lipsum.com/

  b. Generate 20 paragraphs

  c. Copy the Paragraphs

3. Paste the Test Data into the Page

4. Copy the last line on the page.

5. Launch Notepad

6. Paste the text into Notepad

7. Select and copy the text from Notepad

8. Place the cursor at the end of the text in the new page and press "Enter" to go to a new line.

9. Paste the text.

10. Observe the page moves down.

11. Undo the paste (CTRL + Z)

12. Paste the text again.

13. Observe the page moves down even further.

Thank you, Jason for providing those details.

Could you please also mention them on the bug itself, again being:

I posted in an Atlassian-staff comment with your browser versions, but if you also leave a comment with full replication instructions it will help.

Regards,

Shannon

Thanks @Shannon Spaniol

I added the steps to the JIRA issue.

Great, thank you for your help!

Regards,

Shannon

Yes, I often see this issue too and it's very annoying.

Pavel,

If there's a specific pattern you know I can test and replicate it, could you let me know? Then I can track it back to a bug or report it.

Regards,

Shannon

Also let me know if you are also using Cloud as Jason is.

Regards,

Shannon

0 votes

@Jason Tolotta and @Pavel Potcheptsov

I've had a look and it appears it may be this bug:

Can you have a look at that and let us know if that's the issue you're running into? It should occur when you have a lot of content being pasted.

Regards,

Shannon

It looks like this issue describes the bug we've run into.

And it's not for Cloud but for Server too.

Pavel,

Server uses a different editor so it won't be the same bug.

Let me research for you and see what I can find. What version of server do you have?

Shannon

Thank you, Pavel! 

I wasn't able to find anything on this in particular, so could you let me know which browsers you're able to replicate this in? Please test a variety of browsers and let me know the versions as well.

As for my question earlier, if you determine what sort of content causes the issue, please let me know. For example, if pasting several paragraphs only causes it, tables, images, etc.

 

Regards,

Shannon

I'm having the same problem and it isn't restricted to large text being copied. It seems to occur mostly if I select a row or sentence by double-clicking to select the whole row or highlighting in a way that sometimes grabs a space at the end of the text. If I highlight using a character-by-character method (holding the shift key and using the arrow key), I don't seem to have this issue.

This is really disruptive, as we keep very long pages and it's very easy to lose track of the tables I've updated. I am trying to get this to replicate on pages and not able to track a trend or pattern.

The pages where I see this most consistently use:

-Tables (multiple tables per page with cell colors)

-Expand macro

-JIRA Issues macro

-Hyperlinks

-Emoticons

We are using Confluence Server 6.0.5 and Jira Server v7.1.10

Hi Krista,

This particular thread was raised for Confluence Cloud, whereas you are on Confluence Server.

I would recommend raising a support ticket for this if you are able, or raising a new thread related to Server. That way we can help narrow down the issue on your instance.

Regards,

Shannon

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Oct 24, 2018 in Confluence

Atlassian Research opportunity with Confluence templates

Do you use templates with Confluence? Take part in a remote 1-hr workshop. You'll receive USD $100 for your time!   We're looking for people to participate in a   remote 1-hr workshop...

950 views 13 11
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you