Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,250,523
Community Members
 
Community Events
164
Community Groups

Moving entire workspace to new and broken links- 404 error

Hi there,

I am new to Confluence so your help will be really appreciated.

 

I have moved an entire workspace (say 1) into a new workspace (say 3). After the move I moved some other pages from work space (say 2).

So my new workspace 3 has all the content from work spaces 1 and 2. 

Users have started reporting two errors. First was expected but I don't know the answer.

1. Page Not Found- The page you were trying to reach could not be found: it may have been renamed or moved to another space, or the name you requested may be incomplete.

<new workspace link>

If i click on the link it takes me to the new work space which is awesome. How can i eliminate this step of going to earlier work space (1 or 2) and redirecting to new work space (3)? 

2a- On some of the pages when i click a link it takes me to somewhere in a completely other work space (existing work space though). We haven't made any changes but really confused how can this happen?

2b- how should we navigate to original page? Should I restore? If i restore the previous version will it move to the work space I moved from (work space 1?)

Not sure what re-indexing is and if that is the solution? Please guide.

sorry we are using very old Confluence version 4.0.3

Thanks in advance

1 answer

1 accepted

2 votes
Answer accepted
Fadoua Community Leader Jul 15, 2018

Hi Maddy,

Those users reporting the first issue do they have the old URL bookmarked? If yes the error they are getting is completely expected.

Try a search indexing please and let me know how it goes.

Best of luck!

Thanks. 

The way they have added links within the page are the problem. They haven't used the tiny URL (which is a given best practice) instead they have copied the URL from earlier browser and just pasted it in the pages so when they click, it ofcourse goes to old work space which gives message that it has been moved. 

I am worried about point 2 and just to add little more to it-

When i search the information and HIT all- it shows me a list of searched results. I can see the description in little description (under the searched result) but my problem is when I click it- it takes me to another page which had the same page title (for e.g. 'As Built' keyword was used for diff pages and now it seems one of them has replaced another but search result still shows the description in little summary but link is broken.)

When you run a search are you using the quick search or CQL?

Also did you run a search indexing?

Sometimes what I found useful is running queries on the DB itself.

Thanks. We have a huge Confluence so decided to run re-indexing overnight  which i assume should fix most of the linking issues.

I found the solution for other problem. If you have more than one page with the same title then with-in the pages if that page link is called it by default overwrites to the most recent page link. I had two pages 'As Built' and whenever i clicked the link 'As Built' from one of the pages, it took me to another 'As Built'. The simple solution was to update that page title like in my case from 'As Built' to 'As built web'. Just by updating that it fixed the link and redirected to correct 'As Built' link page.

As i said we are running re indexing tonight so see what comes up.

I will keep here posted but thanks much Fadoua. You have been very prompt and helpful. Really appreciate.

Fadoua Community Leader Jul 15, 2018

Let's see how the search indexing goes. Identical titles in different spaces don't make our task as Admin easy at all.

Please keep me posted and in case you still have problems I can ask other Champions for help. The one information to keep in mind is that when some versions are really outdated, Atlassian Team doesn't provide support for them. However we have so many skilled Champions that will be more than happy to assist.

Awesome. Thanks heaps.

Just a quick question- if in old work space users have given hard coded url (copy-paste from browser and not the tiny URL which are independent of work space)- is there any way to correct then when they are moved to new work space.

In new work space when i click on few links they have given take me to old work space and shows me the new work space page. Can i correct those links so that they don't go to old page at all. Reindexing may be helpful but if someone has intentionally added work space specific link, how is that gonna be resolved- that's my next worry now as they are heaps in old work space. :-)

Fadoua Community Leader Jul 15, 2018

Here is a link with some info. I want to wait until you run the indexing.

Best of luck,  I will be waiting for your update.

hi there,

We did re-indexing but couldn't actually see a real benefit as of now. Search works as usual.

The only problem we have is that staff has used browser based URLs to hyperlink pages. Now pages from earlier work space being moved to new work space, if one clicks on one of those links, it shows you old work space with message that this page has been moved to new work space and displays the link in new work space and once clicked it takes you to new work space.

As i said it works but it is unnecessary step and annoys users to click twice. I believe the best practice to hyperlink is using tiny urls (functionality by tool) rather copying browser url as tiny urls are irrelevant to work spaces so in summary I believe i have to fix all links.

Do you have any  suggestion?

Fadoua Community Leader Jul 18, 2018

Hi @Arpit

Sorry to hear that the search indexing didn't help.

Yes Clicking twice to get to the right page is not convenient also sometimes if users don't read the message they think that the page has been deleted and they go into alert mode.

Please click on the following link and see if the suggestion on it will help you. May be you need to do a DB restore before you try it.

Best

Thanks that's helpful. Really appreciate your response and help.

Thanks again. :-)

Fadoua Community Leader Jul 18, 2018

Anytime @Arpit! :)

If satisfied with the help I provided, please click Accept.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Confluence Cloud

Presenter Mode for Confluence is here 🖥 👩‍💻

👋  Hello Community!  My name is Stephanie Zhang, and I’m a product manager on the Confluence cloud team. Today, I’m excited to announce the rollout of  Presenter Mode : a ...

1,555 views 14 35
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you