It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Linking to an anchor on a meeting notes page troubleshooting?

The goal is to have a link to paste into an email that will take the user to the bottom of a long page.

I've followed all the steps on Atlassian's documentation. I've successfully linked to an anchor on a test page. The only difference between the test page and the goal page is that the goal page was made with the meeting notes template.

Now, I know Atlassian is updating the meeting notes template and so some features are going to be out of order while they update them, but anchors were not on that list.

I also tried adding a heading to the place I wanted to link to, but it would not register as a heading. The text changed format when I selected a heading style from the drop down menu, but when I added in a TOC macro it only displayed the template headings.

Does anyone have any other methods to try? Or do I just write this off as a limitation of Confluence during updates to the meeting notes template?

1 answer

0 votes
AnnWorley Atlassian Team Jul 19, 2018

Hi Emily,

It looks like weird behavior with anchors on pages created from templates has been going on for a while so it may not be part of the changes to the editor. Here are two examples: Not able to link text to an anchor on a template page and Anchors on different page are not working as expected. These don't precisely fit your case but show some history of anchor issues, especially using templates.

I am not sure what is happening with the TOC macro and your heading at the bottom of the page. On my test instance, I was able to get the TOC macro to pick up a heading I added to a page after publishing it from a meeting notes template. Please consider opening a ticket on our support portal so someone can have a look at your instance.

Thanks,

Ann

Did you have to publish the page with the added heading to get the TOC to pick it up? I only tried making the heading in edit mode and refreshing the TOC macro preview.

AnnWorley Atlassian Team Jul 19, 2018

Good question. I just tested without publishing first and the TOC preview picked up my "Heading Test" heading:

Screen Shot 2018-07-19 at 12.24.46 PM.png

That is really odd. Did you just press enter from the Date heading to create a new heading? I tried to make a h4 out of a line under "Discussion Items" by highlighting it and selecting a new font type.

AnnWorley Atlassian Team Jul 19, 2018

I did the h4 under Discussion Items and the TOC preview did not pick it up until after I published it. After publishing, I could edit the macro and the preview showed the h4. My theory is the h4 wasn't autosaved yet when I did the initial preview so the TOC couldn't find it.

Would this be considered a bug or does it fall under the construction zone operations?

AnnWorley Atlassian Team Jul 19, 2018

I just did it again and the TOC preview picked up the h4 right away. It could have been a transient condition with my connection or other environmental issue. If I open a bug report for it, the ticket will probably be closed as "cannot reproduce". If you open a support request you can link the support engineers to the exact pages where it is happening and see if it is reproducible on your instance from our network, for example. The issue can be isolated more precisely and a bug opened if appropriate.

Last question: were you able to reproduce my issue with linking to the anchor? Thank you for all your help so far.

AnnWorley Atlassian Team Jul 19, 2018

I was able to link to the anchor on my test instance. Sorry I didn't say so before. 

If the steps to create the link on the test page work but the same steps don't work when you use the Meeting Notes template please open a support ticket with the following:

  • Steps taken to create the link to the test page.
  • Successful link to anchor on test page.
  • URL of the Meeting Notes page that the anchor cannot be linked to.

That way the support team can examine the specific instance where the issue is being reported, compare storage formats of the two pages, see if it works using different steps, etc.

Hello Ann,

I wanted to follow up on the issue with the Anchor macro. I still see that I was not able to create an anchor on a page created from the Meeting Note Template, do you know the current status of this issue?

Thanks 

Sushant

+1 on this, how do you create an anchor on a meeting notes page?

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Posted in Confluence

How is your team having fun and bonding, remotely, utilizing Confluence?

Thanks everyone for answering last week’s question. The winner of the random drawing from those who commented is: @LarryBrock I’ll contact you separately with your prize details. This wee...

327 views 9 7
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you