It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Jira macro in Confluence errors on refresh and does not load Edited

Hello,

I am trying to use the Jira Macro in Confluence to display a list of around 100 issues with three columns.  On opening/refreshing the page, the macro tries to refresh for a few minutes and then brings up an error (as attached). If I refresh the page multiple times, it appears to cache the results and finally loads.

Unfortunately, I need to direct management to this page and I'm not too keen on pointing them to a page that regularly crashes out and requires multiple refreshes.

I had a browse of the forums but couldn't find any issues similar to this one.

Any ideas?

Thanks.

image.pngimage.png

 

1 answer

0 votes

Hi @RL,

Welcome to Atlassian Community. It's nice to have you join us! 

I'm sorry to hear about the problems you're having with the Jira Issues Macro. Is it only this specific filter or amount of results that's causing the issue? Are you able to display other filters with fewer results?

I would recommend that you report this issue to your site administrator, who can log a ticket with the Cloud Support team. We'll be able to have a look at the log files and determine the reason for the Jira issues macro not loading. It could be the number of results, but we would have to see the logs to be sure.

Let me know if you have any questions about that!

Regards,

Shannon 

Thanks Shannon, I have raised an internal IT ticket, so hopefully they will get back to me soon.

Using the same JQL with lower issues (20 or 30) allows it to load quicker (although still takes about 30 seconds). Using Jira itself, I can load the same JQL instantly or even a JQL with 1000+ issues instantly, so it's definitely the macro! 

Cheers

Hi RL,

Thank you for confirming that you were able to raise a support ticket. I tried to find the ticket associated with your email or Cloud domain, but I wasn't able to.

I just wanted to watch the case and see how it's resolved, but if you can just share with us at the end what the issue was, it will help others in the future.

Take care, and have a pleasant weekend!

Regards,

Shannon

Thanks Shannon.

 

I think the ticket is still sat with our IT team. But, I've done some independent testing and it appears to be that the error occurs when using custom fields in the Jira macro. As soon as they are disabled, the macro runs instantly. 

I don't know if that helps narrow down a possible solution?

Like Shannon Spaniol likes this

Hi RL,

It does. I know there have been a couple issues related to custom Jira fields and the Jira issues macro in the past. One, for example, is this one:

To know for sure, we'd want to look at your Cloud site server logs when the macro doesn't load. We can do this if you have your site admin raise a ticket with us.

Thanks, RL!

Shannon

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PRODUCT PLAN
STANDARD
TAGS
Community showcase
Posted in Confluence

Lessons and Learnings: Six Months of Working Remote [Discussion]

Hey there, folks! For most of us, the past six months- yes, you read that right- have been a journey. More people than ever before have pivoted to working remotely, and navigating being on-scre...

8,501 views 6 6
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you