Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Is there a way to turn off automatic issue links? Preferably per link...

We've just spun up our OnDemand instance for Confluence and JIRA. I've noticed that Confluence attempts to autocreate links to issues in JIRA where a potential JIRA-esque issue ID is used. This is going to be a great feature, I'm sure. However...

One of our first pages is about an ethernet-connected hardware device we're working on. The term RJ-45 is used a few times and it appears as a link. You click the link and you're taken to JIRA and told that the issue does not exist.

Is there either a way to instruct Confluence to not automatically link to the issue (preferably per link), or force Confluence to check for the existence of an issue prior to the link?

I've already tried the {nolink} macro. It either didn't work or I didn't use it properly.

Any other thoughts or suggestions?

* edit *

This is what we're seeing now: "blah, blah, blah something about an RJ-45 connector blah."
This is what we'd like to see: "blah, blah, blah something about an RJ-45 connector blah."

4 answers

1 accepted

This is a bug in Confluence OnDemand and reported here. You can try to escap that by leaving a bit of space after the - . Please vote for the bug to be fixed.

How about the code macro?

Jobin, the code macro sets the one term apart in it's own box with different formatting. I've edited my original question to give a clearer example of what we're experiencing and what our desired outcome is. I hope that helps clarify.

Thanks for the quick response!

Renjith, I put the curly braces before, after, and around the "RJ-45". No joy. It's still a URL.

Will escaping it help, with a \ ?

Escaping hyphen with \ seem to work (i.e. RJ\-45). Strange no one else responded to this after so many years... This should be an answer so it's visible on search sites.

Like # people like this

As Dave H. suggested in a comment, put a backslash in front of the hyphen.  ie - for instances of UTF-8 you should type it as UTF\-8 to avoid auto-linking.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Posted in Confluence Cloud

Please tell us how you use Confluence space settings

Hi there, a few of us at Atlassian would love to learn about how you use "space settings" functionality in Confluence. A facelift to the space settings is long overdue and we want to start with impro...

309 views 11 8
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you