Icons on Confluence menubar are replaced by letters in IE8, IE9

Seen in Confluence 5.1:

I don't have a way to post a screenshot here, but the Help, Administration, and Open Notification icons in my Confluence main menu bar are being replaced with the letters "D", "B", and "H" respectively. Also, the application link icon on the far left side of the menubar is replaced with the letter "J". This only occurs in IE 8 and IE 9 (as far as I know). Viewed with Chrome 26.0.1410.63 or latest Firefox, everything looks ok.

Any idea how to fix this?

Thanks,

Jason

17 answers

1 accepted

This widget could not be displayed.

not sure if this applies to everyone but I have had this problem ever since switching to HTTPS.

I ended up rereading the iinstructions here:
https://confluence.atlassian.com/display/CONF35/Running+Confluence+Over+SSL+or+HTTPS where I found this at the bottom:


•Problems with Internet Explorer being unable to download attachments: Applying SSL site wide can prevent IE from downloading attachments correctly. To fix this problem, edit <CONFLUENCE_INSTALLATION>/conf/server.xml and add the following line within the <Context ... /> element:

As far as I can determin its fixed it for me - and allows me to export a page to PDF and getr the results which was waht I was trying to fix :)


This widget could not be displayed.

For reference, I've opened a ticket for this issue:

https://support.atlassian.com/browse/CSP-101545

Thanks John! If your support request gets turned into a bug report for the devs, can you post a link here? I'd love to vote/watch it!
This widget could not be displayed.

we had the same problem and we fixed it:

In IE8 there is a setting for activating/deactivating font downloads. In our case font downloads have been deactivated. Problem was solved by activating them.

security->zone->change zone settings->downloads->font downloads

No effect in IE10. We already had font downloads enabled. Still getting the letters on initial site load and any pag reloads. Haven't yet been able to do all the things Atlassian support told me to.

This widget could not be displayed.

Looks like it's only specific on IE. Please try to install java with IE plugin and check, also check whether your Confluence is on SSL, if it is, please try to turn off SSL and SSL Only restrictions and turn it back on and check.

This widget could not be displayed.

I have the same issue, but in both Chrome and Safari on Confluence 5.2 (not using SSL). Help!

This widget could not be displayed.

We're seeing it with Internet Explorer 10 and Confluence 5.1.2. Most users do not have Java activated on their systems, but I do have it active and it still does it under IE 10.

I can't shut off SSL either. Besides, the other commenter isn't using SSL, so I doubt it's related.

By the way, we are using SSL because our system is accessible via the open web. And no, I'm not going to go through the hassle of turning SSL off to fix this. Atlassian needs to fix this, of course.

Initially we thought it might be related to the Compatibility Mode setting in IE. But additional testing ruled that out. On or off, this issue comes up.

This widget could not be displayed.

I there a resolution to this issue, yet?

This widget could not be displayed.

Same problems on my side, unfortunately.

This widget could not be displayed.

This issue I solving, look for issues :) there are few ways how to resolve it.

This widget could not be displayed.

Hi everyone, there are a few of us internally working on this issue with another customer, so I wanted to give you a little update and also ask for some more info from you.

We are at a stage now where we know this happens across various machines for some instance, but we can confirm from those same machines that the issue does not happen for all instances. Eg, go to http://confluence.atlassian.com in your browsers, and you will likely not see this problem. If you do, please let us know!

So we need to figure out what the commonality in all the instances that experience this is. We are starting to suspect it could be to do with IIS, so we would like to know:

  1. Do you use IIS to serve Confluence?
  2. Is IIS set up as a reverse proxy (ie you use IIS to manipulate the URL/port that users access Confluence on)?

Thanks for all your input here. Hopefully together we can get to the bottom of this!

1. Yes, we use IIS.

2. I do not know if you call that reverse proxy, but we use the URL Rewrite Plugin for IIS. If you need screenshots of our configuration, please let me know.

We're not using IIS. We are using SSL.

PS - I had to use IE to comment here. When I tried to comment from my Chrome 27.0.1453.110 m browser, the comment button turned into a "take me to the top of the page" button.

We are not using IIS. We are using SSL. As I recall we had the same issue before configuring SSL.

Same issue here on production. Vanilla install (Tomcat). SSL enabled IE 8.

No issue on staging server without SSL.

This widget could not be displayed.

We are not using IIS. We are using SSL. As I recall we had the issue before configuring SSL.

This widget could not be displayed.

Any closer to a resolution? I've noticed similar issues when trying to change permissions on a space with IE. Two logos are replaced by "E" and "B"

confluence permissions icons

This widget could not be displayed.
Sean Curtis Atlassian Team Aug 20, 2013

Not sure if this will help but http://blogs.msdn.com/b/ieinternals/archive/2009/10/02/internet-explorer-cannot-download-over-https-when-no-cache.aspx mentions a few other things that might cause this:

Cache-preventing headers include:

  • A Cache-Control header with the tokens no-cache, no-store
  • A Vary header that specifies almost anything
  • A Pragma header that specifies exactly no-cache

Also ensure your server sets the correct mime type for fonts: http://codingstill.com/2013/01/set-mime-types-for-web-fonts-in-iis/

Can you tell us how to set the mime types if we aren't using IIS?

Sean Curtis Atlassian Team Aug 20, 2013

Well it would depend on what server you are using ... I'm sure Googling would yield some results.

I'm running in Tomcat. Based on your post and the google search, I added the following lines to my web.xml:

&lt;mime-mapping&gt;
        &lt;extension&gt;eot&lt;/extension&gt;
        &lt;mime-type&gt;application/vnd.ms-fontobject&lt;/mime-type&gt;
    &lt;/mime-mapping&gt;    
    &lt;mime-mapping&gt;
        &lt;extension&gt;ttf&lt;/extension&gt;
        &lt;mime-type&gt;application/octet-stream&lt;/mime-type&gt;
    &lt;/mime-mapping&gt;
    &lt;mime-mapping&gt;
        &lt;extension&gt;woff&lt;/extension&gt;
        &lt;mime-type&gt;application/x-woff&lt;/mime-type&gt;
    &lt;/mime-mapping&gt;

Note - there was already a mime type for svg.

After restarting, some of my users who previously saw the issue are reporting that it is fixed. But it looks like others are still seeing it - maybe there are multiple causes here?

Sean Curtis Atlassian Team Aug 21, 2013

Jason - can you see if the users still not seeing the fonts can force refresh the page? Ctrl F5 (win), Cmd Shift R (mac). Also there is an IE8/IE9 setting under Toole > Internet Options > Security tab > Custom level... > Downloads > Font download - that might be set to disabled

Also some proxy servers mess with the headers - this can cause IE to not request the font file at all.

Hi Shawn, force refresh didn't do anything. I verified that font download is enabled. So far as I know, there is no proxy involved.

This widget could not be displayed.

Hi Shawn, force refresh didn't do anything. I verified that font download is enabled. So far as I know, there is no proxy involved.

This widget could not be displayed.

Hey all, just to let you guys know that this has already been raised as a bug report here: https://jira.atlassian.com/browse/CONF-29536

This widget could not be displayed.

Maybe that helps: The quick-icons in the header turn into letters only on the homepages of a space, not on the children pages.

I found that when you navigate back up to the Space Home Page after going to a child page it seems ok. Seems to have a problem pulling down icons initially but OK once child page has been loaded

This widget could not be displayed.

Any news about this problem?

I'm interested as well. They load on child pages, but not space home pages.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Monday in Confluence

Why start from scratch? Introducing four new templates for Confluence Cloud

Hi my Community friends!  For those who don't know me, I'm a product marketer on the Confluence Cloud team - nice to meet you! For those of you who do, you know that I've been all up in your Co...

361 views 2 5
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you