How can I disable Synchrony from DB or properties?

This week I upgraded our live Confluence environment to latest as I believe we were approaching end of life for the version we were on. I had a surprise when I found out about the Synchrony / Collaborative Editing functionality. It sounds very nice and fancy, but right now it's stopping my company from editing wiki documents.

Our server is configured in front of a proxy, which I know is part of the complication, but when I go into the admin page to try and disable Synchrony I get an error stating "Something went wrong. Please try again." So I obviously don't want to use Synchrony because it isn't working but I also can't disable Sychrony because the server isn't working. This seems like a catch 22. 

I'd love the opportunity to plan for enabling Synchrony on our own time table, but how can I disable it now (DB setting, or config file) until I can configure it properly.

4 answers

1 accepted

2 votes
Accepted answer

The synchrony.enable.xhr.fallback=true parameter doesn't kill Synchrony, it switches the connection between Confluence and Synchrony to the experimental XHR connection, instead of through the Synchrony proxy.

Disabling Synchrony can be accomplished either through the UI (ConfluenceAdmininstration> Collaborative Editing > Change Mode > Off) or through a rest call against <base_url>/rest/synchrony-interop/disable

The following python script would do the trick:

import requests

def main():
    session = requests.session()

    session.auth = ('admin', 'admin')

    headers = {'X-Atlassian-Token': 'no-check'}
    
    resp = session.post('http://&lt;base_url&gt;/rest/synchrony-interop/disable',
            headers=headers)
    print(resp)
    print(resp.content)

main()

Going off Stephen's answer above, it might be easier to just run the following on a terminal with your admin user credentials and your base URL:

curl -X POST --user admin_user:password --header "X-Atlassian-Token: no-check" https://your.confluence.url/rest/synchrony-interop/disable

 It worked for me. :)

I just realized I wrote about a different issue, but I'd love to get more attention on the page that solved my ultimate issue with Synchrony.

https://confluence.atlassian.com/confkb/after-upgrading-confluence-you-are-unable-to-create-new-pages-or-spaces-785457379.html

 

This page describes a problem where you are unable to Create new pages in Confluence. As it turns out, with Synchrony enabled it also stops you from being able to Edit pages. In addition, I found this page, because a co-worker described to me that they were unable to COPY a page in confluence. So it might be worth expanding the description of symptoms of that KB. Meaning it affects, Create, Copy (which Create does imply Copy), and Edit (with Synchrony enabled).

I FINALLY found the synchrony.enable.xhr.fallback=true property and have killed synchrony and got confluence working again.

Your Troubleshooting Collaborative Editing page should have that section labeled, "When all else fails, disable Synchrony" or something more explicit.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Oct 24, 2018 in Confluence

Atlassian Research opportunity with Confluence templates

Do you use templates with Confluence? Take part in a remote 1-hr workshop. You'll receive USD $100 for your time!   We're looking for people to participate in a   remote 1-hr workshop...

1,125 views 17 14
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you