HipChat Integration Failure

Confluence is running on our Intranet with version 5.6.6. I successfully installed the HipChat add-on plus signed up and created a group on the HipChat site. When I try to preform the integration from our Confluence server I get the error.

Unable to install integration

The value must be an absolute URL

As a test I also setup the add-on with our JIRA instance and tried to integrate it and received the same error as well. I'm wondering if it is because our Confluence/JIRA instances are only internally accessible and have no external access?

2 answers

0 votes
Daniel Wester Community Champion Apr 06, 2015

The JIRA & Confluence servers will need to be able to make outbound requests to api.hipchat.com. If your networking rules don't allow that - that would explain the errors.

0 votes

Hi Kevin,

Daniel is correct. If you are using the Atlassian Hipchat and not your own Hipchat server, then you must have access to the outside.

When setting up the proxy, also make sure that you put the proxy host name and proxy port to allow the correct communication between Confluence/JIRA and the outside.

Cheers,

Rodrigo

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Oct 24, 2018 in Confluence

Atlassian Research opportunity with Confluence templates

Do you use templates with Confluence? Take part in a remote 1-hr workshop. You'll receive USD $100 for your time!   We're looking for people to participate in a   remote 1-hr workshop...

1,037 views 15 13
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you