Getting system error after installing Confluence server

Hi 

I am trying to use confluence server, i have dowloaded and installed it. It causing me an error at the last step while it says finish updates and opens with system error page on browser. Do I have to login in into Confluence cloud or sign in before using server? While I was using trial of Confluence Server, I have used Cloud of free trial which I got deactivated due to not useful for my system. Is there anything I am doing wrong while Installing it?

Do I need virtual box to use Confluence Server?

I look forward to you.

 

Thanks 

Shazia

1 answer

0 votes

Cloud and Server are totally separate systems.

I assume you are trying to run a Confluence server on one of your servers, or maybe even your own machine, which is absolutely fine.  Yes, you can run it on a VM, but it's not necessary.  It'll run on any machine that runs the right version of java and has enough power to support it.  You can forget Cloud for this.

You'll need to read, diagnose and fix the system error you have.  If it's not giving you enough information to understand it (quite likely, they can be totally cryptic), then have a look at the log files for more information on what is going wrong.

Thanks a million for your response. I am using "Java 8 updates 31" I do not if it is good to run server. I have tried again to install and open it still getting same error. can you please have a at the following text I am not if that is the problem I am getting. 

I am not administor on Laptop I am using user account, Do you think that is stopping me to use server? but I have downloaded and installed it. 

Caused by: java.lang.IllegalStateException: Spring Application context has not been set
	at com.atlassian.spring.container.SpringContainerContext.getComponent(SpringContainerContext.java:48)
	at com.atlassian.spring.container.ContainerManager.getComponent(ContainerManager.java:33)
	at com.atlassian.confluence.util.LazyComponentReference$Accessor.get(LazyComponentReference.java:42)
	at com.atlassian.util.concurrent.Lazy$Strong.create(Lazy.java:85)
	at com.atlassian.util.concurrent.LazyReference$Sync.run(LazyReference.java:325)
	at com.atlassian.util.concurrent.LazyReference.getInterruptibly(LazyReference.java:143)
	... 193 more

 

I look forward to you.

 

Thanks 

 

That error can be caused by a number of things.  Often, your version of java, but there's other causes.

Could you work your way further through the error logs - you should be seeing a number of "caused by" after that line.  Might be worth looking at the lines before it as well.

Hi Nic

No this is the only one "Caused by"  I got, there is no more as I took above text from very bottom lines. I do not understand what that mean. Can you figure out this error please? 

Thanks

Shazia

Ok, then you're definitely going to have to work upwards through thelog - where do the errors start?

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Oct 24, 2018 in Confluence

Atlassian Research opportunity with Confluence templates

Do you use templates with Confluence? Take part in a remote 1-hr workshop. You'll receive USD $100 for your time!   We're looking for people to participate in a   remote 1-hr workshop...

1,521 views 25 14
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you