Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Export CSV Error with Insight Macro for Confluence

Hi, 

I'm trying to use the Export to CSV feature on the Insight Macro for Confluence, and I'm receiving the following error code message when I attempt to do so: 

The CSV export failed.

TypeError: Td(...) is not a function

The report itself works great, it's just the export function that is not working. Is anyone else getting the same error message or having similar issues with feature? 

We're currently on Confluence 7.4.3 and Insight Macro for Confluence 1.6.4. 

Thanks,
Joseph

 

1 answer

1 accepted

0 votes
Answer accepted

Also interested as we see the exact same issue here since updating to 1.6.4:

Confluence 7.4.1 and Insight for Confluence 1.6.4.

Hi @Carl Belinger,

So this feature worked for you before updating to 1.6.4? We just started using this macro so we don't know what the CSV report looks like or if it ever worked.

I opened a support ticket with Atlassian. I'll let you know what I find out. 

Thanks.

Hi @Joseph Orellana 

Yes.  We had to use that as the previous version crashed Confluence when using export to PDF.

Just seen that Insight for Confluence now has an update to 1.6.5 which fixes this issue:

JSDSERVER-7208

IMFC - Cannot export to CSV

Updated to 1.6.5 here.

CSV export now working !! :-)

Same here. 1.6.5 solved the issue for us as well. Thanks for the help, Carl. 

Hi @Carl Belinger 

Did you find that v1.6.5. solved the PDF issue you mentioned? I tested it and it seems to work, but I just wanted to confirm. I also found this mindville ticket: https://jira.mindville.com/browse/IMFC-82. 

Thanks,

Joseph

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Confluence

🥓🙅🏻‍♀️ Meet-less May Badge!

Hello Confluence Community!  What if i told you that you could have a healthier life and be 100% meet-less? This month, we're promoting a healthy, balanced work diet with Confluence. (Read m...

359 views 3 18
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you