It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Expand menu macro does not function inside a tabs page.

I created my Tabs container  macro> tabs page macro > Expand macro which has 3 items listed.

This macro works everywhere I have used it, so far, but inside a tabs page, the arrow does not expose the 3 child menu items. 

Is this a broken behavior or just not supported? Thanks.

2 answers

1 accepted

1 vote
Answer accepted

Hi @ElizabethC ,

  How are you making your tabs container? Is this an add-on? Expand macro comes with Confluence but I don't see a tabs. 

Another option is to have your admin download the free app Refined Toolkit for Confluence from RefinedWiki.  This came with UI Tabs and UI Expand. These work well together.

a.jpg

 In my confluence there is Tabs Container, then inside that you put tabs pages macros, and they become the tabs.  

In this tabs page I am trying to use an expand menu. 

This is what I was doing. 

I will give the Easy Dropdown menu a try! Thanks!ConfluenceTabmenuIssue.JPG

I see I can "request" but as I am not our main space's administrator, (I just have admin rights to child pages) I am not sure how you go about adding this macro to what I see when I do the "Other Macros" option. 

Oh wait I see what happens the site admin gets the request. 

Jonathan Smith Community Leader Mar 27, 2019

@ElizabethC ,

  The tabs page / tabs container is more than likely an installed macro. You can always ask your admin to open a case with that vendor to address your expand situation.

Also, based on the macro naming, your tabs page should be on the outside with tabs containers on the inside. Give this layout a shot:

Tabs Page

--- Tabs Container

--- --- expand

--- --- expand

--- Tabs Container

--- --- expand

--- --- expand

b.jpg

Again, I don't have this macro, but it sounds like your content (expand macros) would live in the "container".

- Jonathan

Jonathan Smith Community Leader Mar 28, 2019

@ElizabethC Interested to know if switching tabs page and container fixed your situation.

- Jonathan

Jonathan Smith Community Leader Mar 28, 2019

@ElizabethC ,

  I updated the first post. The UI Tabs and UI Expand is from a different vendor. This add-on is free!

- Jonathan

I ran into the same issue, looks like the same vendors as the OP.  It works in the preview, but not when saved.  

Switching the containers and pages layout very much did not work.

Try turning off lazy loading.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Posted in Confluence

Lessons and Learnings: Six Months of Working Remote [Discussion]

Hey there, folks! For most of us, the past six months- yes, you read that right- have been a journey. More people than ever before have pivoted to working remotely, and navigating being on-scre...

8,340 views 6 6
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you