Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,456,807
Community Members
 
Community Events
176
Community Groups

Expand menu macro does not function inside a tabs page.

I created my Tabs container  macro> tabs page macro > Expand macro which has 3 items listed.

This macro works everywhere I have used it, so far, but inside a tabs page, the arrow does not expose the 3 child menu items. 

Is this a broken behavior or just not supported? Thanks.

3 answers

1 accepted

1 vote
Answer accepted

Hi @ElizabethC ,

  How are you making your tabs container? Is this an add-on? Expand macro comes with Confluence but I don't see a tabs. 

Another option is to have your admin download the free app Refined Toolkit for Confluence from RefinedWiki.  This came with UI Tabs and UI Expand. These work well together.

a.jpg

 In my confluence there is Tabs Container, then inside that you put tabs pages macros, and they become the tabs.  

In this tabs page I am trying to use an expand menu. 

This is what I was doing. 

I will give the Easy Dropdown menu a try! Thanks!ConfluenceTabmenuIssue.JPG

I see I can "request" but as I am not our main space's administrator, (I just have admin rights to child pages) I am not sure how you go about adding this macro to what I see when I do the "Other Macros" option. 

Oh wait I see what happens the site admin gets the request. 

@ElizabethC ,

  The tabs page / tabs container is more than likely an installed macro. You can always ask your admin to open a case with that vendor to address your expand situation.

Also, based on the macro naming, your tabs page should be on the outside with tabs containers on the inside. Give this layout a shot:

Tabs Page

--- Tabs Container

--- --- expand

--- --- expand

--- Tabs Container

--- --- expand

--- --- expand

b.jpg

Again, I don't have this macro, but it sounds like your content (expand macros) would live in the "container".

- Jonathan

@ElizabethC Interested to know if switching tabs page and container fixed your situation.

- Jonathan

@ElizabethC ,

  I updated the first post. The UI Tabs and UI Expand is from a different vendor. This add-on is free!

- Jonathan

I ran into the same issue, looks like the same vendors as the OP.  It works in the preview, but not when saved.  

Switching the containers and pages layout very much did not work.

Try turning off lazy loading.

I had the same problem ... turning off lazy loading worked, thanks! 

Like Sean Dooley likes this

This worked for me as well.  Thanks!

Like Sean Dooley likes this

I do not think Expand can contain tabs by design. I think it should though.

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events