Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Error when trying to update confluence template

Hello! I am trying to update an existing confluence template (which was not created by myself). I can hit the edit button and go the template editor. However, when I click "save" in the editor, it says "There was an error processing the request" and won't let me save. I've confirmed that it is not a permissions issue, and I do have the permissions to make this edit.

Is this a bug and / or is there a way to get around this?

I've tried this several times on different days and got the same error each time. I'm not sure if I'm the only user experiencing this or if others are as well. The original template creator is able to edit the template successfully. 

Would appreciate any advice, thank you!

 

1 answer

0 votes
Diego Atlassian Team Mar 18, 2021

Hello @Evelyn Shaw!
The behavior you are facing is indeed unfortunate. I have seen this in the past when some problematic content was copy and pasted from somewhere else.

We need to understand more about your situation. With this in mind, I came up with these questions:

  1. What kind of changes are you applying to the template?
  2. Did the template owner try to edit the template with the same changes as you?
  3. What happens if you copy the whole content from the template and try creating a new template?
  4. Are you able to edit any other template?

Also, since it has been a few days since you reported this behavior, I would like to understand if this is still present. Also, would it be possible for you to check if there is anyone else who is affected by this?

Let us hear from you.

Hi Diego, 

Thanks for following up. I just tried to edit the template again and it works now!  Not sure what happened exactly to fix it. During the time it wasn't working, I did try actions related to your questions 1 & 2 so included that info below. Unfortunately didn't have a chance to try 3 & 4. 

1. I tried to edit the text to the template, as well copying new text in from another confluence page. In both cases, it gave me the same error (even when I tried just adding 1 character).

2. The template owner was able to update the template with the same changes, and that's what I ended up doing as a workaround while it still wasn't working for me. I verified after the owner made the change that I was still unable to edit, so it does not appear that that action was what caused it to start working again. 

Thanks again for checking in. If you do want other info, let me know. I'm glad that it appears to have resolved itself.

 

Best, 

Evelyn

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PRODUCT PLAN
STANDARD
TAGS
Community showcase
Published in Confluence

Confluence Mythbusters: Does Atlassian even use Confluence?

Hi, Confluence collaborators! As part of #Confluence-Collaboratory month, we’ve created a very special Mythsbusters segment, where we're dive into an interesting myth and uncover the truth behind i...

1,704 views 7 32
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you