Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Embedded PDFS no longer work

Good day,

 

I had updated from 6.13.1 to 7.0.3 and I'm experiencing an issue with embedded pdfs not being rendered. 

https://www.screencast.com/t/JmiwRQlCkKpY

I've tried disabling plugins to see if that could be the cause, in addition to looking for other plugins that provide the same functionality with no luck so far.

1 answer

0 votes

Hi Jeffrey,

Welcome to Atlassian Community! It's nice to have you.

I think you could be running into one of these bugs: 

Some things to consider:

  1. Does this occur with all PDFs, or only certain ones?
  2. Does this occur only when using the viewfile macro or also with the file preview
  3. Check your Confluence Server Logs and see what message is returned when you try to load the PDF preview?

Thank you for your help!

Regards,

Shannon

Hi Shannon,

Thanks for the reply. To answer your questions:

1. This issue is occurring with all pdfs.

2. This issue is only occurring with the viewfile macro, The attachment can be viewed if I add a thumbnail.

3 I'm getting the following error in my log file when I open posts with PDFs embedded,

 https://www.screencast.com/t/1wRgOvok

Hi Jeffrey,

Thank you for your reply. I think you could be affected by one of these known bugs. Are you able to obtain more details regarding that error message? The snippet you sent is helpful but it appears to be lacking the error message that triggers the null pointer exception. If you look further up you should be able to get the rest of the stack trace, including the error message (marked by the word ERROR at the start.)

Regards,

Shannon

Hey Shannon,

 

I've managed to obtain the full error message, I hope this is more helpful. 

 

https://www.screencast.com/t/llWyR3mh

Jeffrey,

Thank you for that. This shows the same error from the bug I sent you earlier which is:

There's no workaround to get the viewfile macro working, so the solution at this time is to not use the ViewFile macro to display your PDF files.

Let me know if you have any questions about that.

Regards,

Shannon

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Posted in Confluence

What do you think is the most *delightful* Confluence feature? Comment for a prize!

- Create your own custom emoji 🔥 - "Shake for Feedback" on mobile 📱 - An endless supply of GIFs via GIPHY 🤩 Is there anything quite as nice as a pleasant surprise? Comment below with what...

402 views 23 8
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you