Drag and drop doesn't work on Attachment macro unless same page?

Hi -- if I have an attachment macro on a page to display attachments for that page, the drag and drop function works fine. If, however, I'm using an attachment macro to displays attachments from a different page, the drag and drop does not work -- users have to go to the original page, drag and drop, and return. If they drag and drop on the page where I want the attachments to be displayed, it gets added but doesn't appear (you have to click on the paperclip). Does anyone have a solution where my users can drag and drop on the attachment macro and have them appear (without having to drag and drop on a different page)? Thank you!

2 answers

1 accepted

Hi Natalie,

Actually, I don't have a solution for this case right now, but since I was able to reproduce this problem, I believe that it's a bug. Being said that I raised a bug report as you can see here:

https://jira.atlassian.com/browse/CONF-29797

I would strongly suggest that you vote on this issue to increase its popularity and add it to your watchlist for future updates.

Cheers,
WZ

Attachment macro able to display attachments from another page if page title, the macro will display the files attached to the current page.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Oct 24, 2018 in Confluence

Atlassian Research opportunity with Confluence templates

Do you use templates with Confluence? Take part in a remote 1-hr workshop. You'll receive USD $100 for your time!   We're looking for people to participate in a   remote 1-hr workshop...

964 views 14 12
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you