Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Disappeared top menu items, like spaces, create etc.

Alex Isaia (tech) January 28, 2019

Hello!

Today disappeared top menu buttons and there's no way to quickly change space, create page and so on (please see screenshots).

I'm global admin on this Confluence installation. Tried in different browsers. Also tried to restart Confluence and purge Confluence's cache.

There is Nginx before Confluence, but if I try to follow direct link to Confluence omitting Nginx, I'll receive the same situation as with Nginx.

<confluence installation>/logs/catalina.out - clear

<confluence data>/logs/atlassian-confluence.log - clear too

I use default theme, no customizations were made.

There are no duplicates in DB table AO_187CCC_SIDEBAR_LINK

 

I have several errors in browser's developers console:

1. DEPRECATED JS - Cookie has been deprecated since 5.8.0 and will be removed in a future release. Use cookie instead

2. Value of "AJS.$.fn.enable" was overridden

3. Value of "AJS.Confluence.QuickEdit" was overridden

4. DEPRECATED JS - Dialog has been deprecated since 6.0.6 and will be removed in a future release. Use require('confluence-create-content/space-blueprint')

5. DEPRECATED JS - Inline dialog constructor has been deprecated and will be removed in a future release. Use inline dialog 2 instead. (this messages around 5)

6. Remove legacy sidebar code when upgrade to AUI 5.8+

7. Value of "Confluence.Defaults" was overridden

8. Value of "AJS.Rte.Support" was overridden

9. AJS's create element functionality has been deprecated since 5.9.0. No alternative will be provided. Use document.createElement() or jQuery.parseHTML(), or preferably use a templating library.

 

 

Confluence version - 6.2.1Screen Shot 2019-01-28 at 14.51.04.png

 

I've been googled for it for almost 5 hours but without any success. I've tried different options to fix it, but without any kind of success.

Could anyone help me with it? Or at least show a way where I should find answer?

 

Thanks a lot!

2 answers

1 accepted

1 vote
Answer accepted
Shannon S
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
January 29, 2019

Vitalii,

I've seen those messages quite often in Chrome so I don't believe they are related.

Can you confirm your Confluence version for us?

I would try the following:

  1. Does the issue still occur in Incognito Mode in Chrome or with all Chrome add-ons disabled?
  2. Put Confluence into Safe Mode and see if you can still replicate the issue.
  3. Remove all customizations in Confluence and see if that corrects the issue.

Some other things to consider:

  1. Does the problem occur for all users?
  2. Do you have the same issue no matter which browser you use? Have you tried multiple browsers, such as Firefox, IE, Safari, etc.?
  3. Does this issue occur on more than one computer?

Thank you for your help!

Regards,

Shannon

Alex Isaia (tech) January 29, 2019

Hello, Shannon!

 

Thanks for your answer.

I've figured out the main reason - license :)

The thing is that I've migrated Confluence from one server to another with different database type using XML export method. For the first start of the server I used a trial key and forgot to update it after backup import, so my trial key expired and as a reason top menu disappeared.

But now I have another issue - my server doesn't want to work with old license key - it says it's incorrect, so now I'm speaking with support team.

 

Anyway, thank you for your answer!

Like # people like this
Shannon S
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
January 29, 2019

Thank you for letting me know, Vitalii. Happy to hear that they're helping you with your license issue.

Regards,

Shannon

0 votes
阿波罗的海
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
March 19, 2024

Put Confluence into Safe Mode solved

Suggest an answer

Log in or Sign up to answer
TAGS
AUG Leaders

Atlassian Community Events