Disable auto-formating when i paste a link

Hello!

In our Company we'd like to define our project solutions in Confluence. The pages that contain these informations are then reviewed in a status meeting.
In the meeting notes we then want to insert a link to that specific version of the page, that was discussed in that meeting.

image2016-1-20 16:5:18.png

The link to that specific version is generated from Confluences-Page Metadata following the guide of Jon Schneider. We create a "copy to Clipboard" element (HTML macro) at the top of our pages. (http://blog.jonschneider.com/2010/02/confluence-wiki-linking-to-diff-against.html)

copyToClipboard.png

In the end a link in the following format is generated:
 http://<ourServer>/pages/viewpage.action?pageId=3014687&pageVersion=29

 

That works very well. However when i copy that link to my clipboard and paste it into the edit-page control the pageVersion Parameter of the URL gets automatically removed.

The links gets inserted correctly but after a short amount of time it gets auto-formatted. (I provided some screenshots at the end of this Question.
This of course can be resolved by changing the type of the link to "Link to Website" but for that i need 3 additional actions and i have to paste the link once more. 

We like what Confluence does with a link through auto-formatting but we want it to keep the pageVersion Parameter. Is der any way to resolve this? 
or What are the "standard" practices when one wants to achieve that kind of behaviour. 

Original

2016-01-20_15-58-54.png

Formatted

2016-01-20_15-59-31.png

Actual target of the formatted Link

2016-01-20_15-59-52.png

 

We are using Confluence 5.8.14.

Best Regards.

2 answers

1 accepted

We could not resolve the discribed behaviour but we now use the generated URL in a different way. So this needs no more resolving for us.

Hi Florian,

This functionality (Auto formatting) is provided by Confluence Editor. You can disable the editor's autocomplete and autoformatting functions, by editing the settings in your user profile.

In summary:

  1. Choose your profile picture at top right of the screen, then choose Settings.
  2. Choose Editor under 'Your Settings' in the left-hand panel.

For more details, see Editing User Settings.

Cheers,

ENunes

Hi ENunes

Thank you for your answer.

I found those settings thanks to your description. I deactivated both autocomplete and autoformatting function but when i paste a link i gets formatted on most of the pages and not formatted on some fewer pages in my space.

The two screenshots were made on two different sites today after i deactivated both features and logged off and on. In both cases i pressed the copy to clipboard button (to copy the link http://<ourServer>/pages/viewpage.action?pageId=1769817&pageVersion=31) and inserted it using CTRL+V.

2016-01-21_08-11-58.png2016-01-21_08-13-11.png

I tried logging on and off with my user. Do i have to restart the server? Or am i missing something?

Best Regards

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Kesha Thillainayagam
Posted Apr 13, 2018 in Confluence

We want to hear how your non-technical teams are using Confluence!

Hi Community! Kesha (kay-sha) from the Confluence marketing team here! Can you share stories with us on how your non-technical (think Marketing, Sales, HR, legal, etc.) teams are using Confluen...

366 views 20 10
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you