Disable Wiki Markup

Hi,

I am a new user to Confluence, and it involves maintaining my documents. It is really painful when I see 'Wiki Markup' displaying completely random thing in markup that I have no idea about.

I just need to disable this thing for my User account! I really hate it to the maximum when its a huge document with lot of tables.

Please help!

3 answers

You can't disable it, and it can be really helpful when you need to do something custom. But more importantly, if you are seeing markup in edit mode, then that means that someone before you used it; if it could be disabled, you would lose content.

But the editor doesn't preserve text with the markup correctly anyway.

So simply editing a comment in JIRA, and saving it, can corrupt the text if you accidentally trigger a text effect substitution (I think server side).

I'm raise a bug, but basically let me switch it off please, quietly corrupting my text is confusing and annoying, especially as I was just trying to type a paragraph.

0 vote
Stephen Deutsch Community Champion Oct 06, 2015

Hi Santosh,

If you want to, you can replace the wiki markup with normal Confluence editor formatting.  Here's what you need to do:

  1. Copy the entire content of the "Wiki Markup" macro (a single one; you have to do this one at a time).
  2. Put the cursor directly above the macro (or delete it).
  3. Click on "Insert", "Markup", and paste the wiki formatted text into the field.  It should show a preview on the right.  You need to make sure that "Confluence wiki" is selected from the dropdown box.  Then click "Insert"
  4. If you didn't delete the macro in step 2, delete it.

Now the wiki markup content should be in Confluence editor format.  You should check with the person who made the page originally if there was any reason behind leaving the content in wiki markup, but nowadays there really is not much reason to do so, since it has been phased out since the beginning of Confluence 5, which has already been a few years smile

If you find out you made a mistake or it doesn't display correctly or whatever, then you can simply go to the page history and restore the last version.  That's the beauty of having a wiki laugh

0 vote
Steven Behnke Community Champion Oct 07, 2015

Don't these Profile Settings help in this case: 

  • Disable Autocomplete in the Editor, where it allows links to be inserted with the trigger [ and images with the trigger !
  • Disable Autoformatting in the Editor, where it allows wiki-formatted text to be converted to its Rich Text equivalent (e.g. "h1. title" for a heading).

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Kesha Thillainayagam
Posted Friday in Confluence

We want to hear how your non-technical teams are using Confluence!

Hi Community! Kesha (kay-sha) from the Confluence marketing team here! Can you share stories with us on how your non-technical (think Marketing, Sales, HR, legal, etc.) teams are using Confluen...

301 views 11 10
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you