Create button disabled when creating a new wiki space Edited

We're using Jira and Confluence, both the cloud versions and also bitbucket for development of some projects.

I'm creating a "Software project space" within Confluence to link to a JIRA project that I've just created successfully.  I've picked the newly created project name from the list and all the fields have been populated including the Space key, which it's defaulted to the same key as the project.  All required fields are filled out, however, the Create button is still "greyed" out, and so I can't create the space.

Creating a blank space doesn't have this issue, but I haven't followed through as I don't want to burn the space key.

 

2 answers

1 accepted

Accepted Answer
0 votes

Since you have the create space permission for blank spaces it likely isn't a permission problem.

 

The only thing I can think of is your space key being unique.  Is there a similarly named space in your Confluence instance that is blocking you from creating?

No, I've checked and there's no space, either current or archived with that key.

check in the admin panel if you've disabled the "software project space" blueprint.

Hey good idea, but no, I can see that option and it's enabled in the Global Templates and Blueprints area of the Confluence configuration section.

What browser are you using?

I see a related issue here for chrome: 

https://community.atlassian.com/t5/Confluence-questions/Can-t-create-software-project-space-with-a-space-key-modified/qaq-p/161079

Try doing it with another browser

Ah Chrome.  OK thanks, I'll give that a go and let you know.

Still no joy, I tried Firefox and Safari.

I saw that one too, they were able to click create and got an error on submit, but I can't even click it.

can you attach a screenshot?

Yeah, here you go.

Screen Shot 2018-05-10 at 3.27.38 pm.png

Would be possible to verify if your license has reached the maximum number of licensed users? Check this on Confluence administration -> license details and verify the number of current licensed users.

If license is not a problem for your instance then you may try the resolution in the KB article create-space-button-inactive-in-add-space-dialog.

Thanks @Rambabu Patina [Appfire], but neither of those look applicable to us here as we're using the Atlassian hosted cloud instance.

I just tried to create a whole new fictitious project and space, which worked successfully.  Maybe someone had previously created a space with that key, then subsequently deleted it, and there are some artefacts remaining somewhere.  I did see some older questions talking about it being an issue but that was in the server version too not the cloud.

Ah, yes, found it.  Under https://company.atlassian.net/wiki/admin/permissions/viewdefaultspacepermissions.action I can see the key I'm wanting to use.  I might be able to recover and reuse it from there.

Check whether you have right permissions to do so

No, I'm in all the administrator groups.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Oct 11, 2018 in Confluence

What are your project planning tips?

Hello Community,  Jessica here from the Confluence product marketing team! Today I wanted to get your takes on project planning –– what works, what doesn’t, how do you know if you’re doing it r...

261 views 1 4
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you