Confluence will not display correctly in Firefox

Whenever I open Confluence in Firefox, I frequently get a blank page with plain text or a page where the header links are all in a list and overlapping each other, like the style sheet/page design must not be loading at all.

I'm running Firefox 25.0 on Windows 7. Nothing I seem to do--clearing cache/cookies, restarting Firefox, restarting my computer--seems to help. Did I accidentally select the wrong settings to use Firefox?

I know Confluence works best with IE, but I do NOTHING else in IE and it's a huge hassle to switch browsers back and forth all the time.

Please help! Sometimes it also repeats the image tabs at the top all across the page, effectively displaying a bunch of grey and white stripes over my content. It's unusable.

4 answers

1 accepted

This widget could not be displayed.

Fixed via reinstalling Firefox.

This widget could not be displayed.

Confluence works best with IE? That's a new one to me, as IE seems to be the only one that gives me any problems!

Anyway, is it possible to try it quickly in Chrome? If it's ok there, then it proves it's a firefox issue, if not, then there's something really odd going on! Either way, could you also try Firefox in "safe mode" (you've tried all the other things I'd say to try with the browser), so there are no plugins loaded at all? I've run into loads of problems with Firefox, but only two turned out to be unrelated to plugins, and both of them were bugs in Confluence affecting all browsers...

It seems to work fine in Chrome.

I tried turning off plugins when it started acting up again.

That didn't work. It still got to a point where it won't load.

Now I just get a blank page and nothing loads.

Hmm, then there's something odd in the core of firefox then. (You did mean you turned off all your Firefox plugins, not Confluence ones?). Might be worth looking at colleagues Firefoxes too - it works fine here for me.

This widget could not be displayed.

I'm also getting similar issues. I just tried loading the same page in FF and IE.

FF: side nav bar never loaded and status kept spinning

IE: loaded fine

Chrome: loaded fine

This widget could not be displayed.

If anyone experiences this issue again, the solution would be pressing CTRL-F5.

This is not just a way of refreshing the page (like CTRL-R) in Windows, but it also clears the browser cache and forces it to download the assets to a page as if you've never been there before.

I posted this comment, since it's a fairly valuable thing for Project Managers to know as well.  It will allow you to see your teams work with "fresh eyes" (although a small discussion over coffee can help as well.)  wink

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Published Tuesday in Confluence

Add-on evaluation with confluence templates

Atlassian market place contains number of Apps/Addons which improves the capability of out of the box Atlassian products. It is good to follow a plugin evaluation process before install add-ons. So t...

102 views 12 6
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you