Confluence server with apache proxy not working on subdomain

I've been stuck the past few hours trying to enable my subdomain to access confluence on port 80, I've followed countless guides and community posts although nothing seems to fix the issue I'm facing.

 

Some of the articles I've followed are:

https://confluence.atlassian.com/kb/proxying-atlassian-server-applications-with-apache-http-server-mod_proxy_http-806032611.html

https://confluence.atlassian.com/doc/using-apache-with-mod_proxy-173669.html?_ga=2.155400761.30572380.1524732386-924432085.1524732386

https://confluence.atlassian.com/conf59/using-apache-with-mod_proxy-792499652.html?_ga=2.264527117.30572380.1524732386-924432085.1524732386#UsingApachewithmod_proxy-complex

 

And a lot of user posts:

https://community.atlassian.com/t5/Confluence-questions/Get-Confluence-working-on-a-subdomain/qaq-p/624173

https://community.atlassian.com/t5/Confluence-questions/How-can-I-use-Confluence-on-a-subdomain/qaq-p/713700

https://community.atlassian.com/t5/Confluence-questions/Confluence-behind-Apache-How-to-address-Confluence-by-subdomain/qaq-p/340500

https://community.atlassian.com/t5/Jira-questions/how-do-I-set-up-Jira-at-a-subdomain/qaq-p/401859

https://community.atlassian.com/t5/Confluence-questions/Apache-Config-for-Confluence-6/qaq-p/144625

https://community.atlassian.com/t5/Confluence-questions/Confluence-Server-behind-Apache-proxy-not-working-with-SSL/qaq-p/721084

https://community.atlassian.com/t5/Confluence-questions/Running-Confluence-on-Port-80/qaq-p/219911

https://community.atlassian.com/t5/Confluence-questions/How-to-Configure-Confluence-server-IP-port-from-8090-to-80/qaq-p/47325

 

But I'm still facing the same issue... I'm able to use my subdomain through confluence.domain.tld:8090 to access confluence although I cannot access it through confluence.domain.tld or confluence.domain.tld:80 as it returns an internal server error each and every time (regardless of the modifications I make)

 

My current setup is an Apache Virtualhost with mod_rewrite, mod_proxy, mod_proxy_html and mod_proxy_wstunnel enabled.

 

My virtual host file is as follows:

<VirtualHost *:80>
    ServerName confluence.domain.tld
    #ServerAlias confluence
    #DocumentRoot /opt/atlassian/confluence
    #ErrorLog /opt/atlassian/confluence/apache/confluence-error.log
    #CustomLog /opt/atlassian/confluence/apache/confluence-access.log common
    ProxyRequests Off
    ProxyVia Off
    ProxyPreserveHost On
    ProxyPass /synchrony http://confluence.domain.tld:8091/synchrony
    <Location /synchrony>
        Require all granted
RewriteEngine On
        RewriteCond %{HTTP:UPGRADE} ^WebSocket$ [NC]
        RewriteCond %{HTTP:CONNECTION} Upgrade$ [NC]
        RewriteRule .* ws://confluence.domain.tld:8091%{REQUEST_URI} [P]
    </Location>
    <Proxy *>
        Require all granted
    </Proxy>
    ProxyPass / http://confluence.domain.tld:8090
    ProxyPassReverse / http://confluence.domain.tld:8090
    #RewriteEngine On
    #RewriteCond %{REQUEST_URI} !^/synchrony
    #RewriteRule ^/(.*) http://confluence.domain.tld:8090/$1 [P]
    #ProxyPassReverse / http://confluence.domain.tld:8090
    <Location />
        Require all granted
    </Location>
</VirtualHost>

And I have also appended my server.xml appropriately as follows:

<Connector port="8090" connectionTimeout="20000" redirectPort="8443"
maxThreads="48" minSpareThreads="10"
enableLookups="false" acceptCount="10" debug="0" URIEncoding="UTF-8"
protocol="org.apache.coyote.http11.Http11NioProtocol"
proxyName="confluence.domain.tld" proxyPort="80" scheme="http"/>

The backend of confluence also displays the my subdomain as the base url. 

 

Any help from here would be greatly appreciated to fix this issue.

Thank you

1 answer

1 accepted

1 vote
Accepted answer

what is the error you are getting in apache log when you are hitting?Do you have a LB in from of apache?

Here is the error log I've obtained from apache that relates to confluence:

[Sat Apr 28 05:31:12.212494 2018] [proxy:warn] [pid 14139:tid 139749176080128] [client XXX.XXX.XXX.XXX:53315] AH01144: No protocol handler was valid for the URL /download/resources/com.atlassian.confluence.plugins.system-templates:system-template-resources/assets/images/welcome.png. If you are using a DSO version of mod_proxy, make sure the proxy submodules are included in the configuration using LoadModule., referer: http://confluence.domain.tld:8090/dashboard.action
[Sat Apr 28 05:38:34.928335 2018] [mpm_event:notice] [pid 14137:tid 139749477999808] AH00493: SIGUSR1 received. Doing graceful restart
[Sat Apr 28 05:38:34.933203 2018] [mpm_event:notice] [pid 14137:tid 139749477999808] AH00489: Apache/2.4.25 (Debian) configured -- resuming normal operations
[Sat Apr 28 05:38:34.933213 2018] [core:notice] [pid 14137:tid 139749477999808] AH00094: Command line: '/usr/sbin/apache2'
[Sat Apr 28 05:38:40.339734 2018] [mpm_event:notice] [pid 14137:tid 139749477999808] AH00493: SIGUSR1 received. Doing graceful restart
[Sat Apr 28 05:38:40.344346 2018] [mpm_event:notice] [pid 14137:tid 139749477999808] AH00489: Apache/2.4.25 (Debian) configured -- resuming normal operations
[Sat Apr 28 05:38:40.344359 2018] [core:notice] [pid 14137:tid 139749477999808] AH00094: Command line: '/usr/sbin/apache2'
[Sat Apr 28 05:38:46.774792 2018] [proxy:warn] [pid 15151:tid 139749234829056] [client XXX.XXX.XXX.XXX:58932] AH01144: No protocol handler was valid for the URL /. If you are using a DSO version of mod_proxy, make sure the proxy submodules are included in the configuration using LoadModule.
[Sat Apr 28 05:38:47.650349 2018] [proxy:warn] [pid 15152:tid 139749321533184] [client XXX.XXX.XXX.XXX:58933] AH01144: No protocol handler was valid for the URL /favicon.ico. If you are using a DSO version of mod_proxy, make sure the proxy submodules are included in the configuration using LoadModule., referer: http://confluence.domain.tld/
[Sat Apr 28 05:53:40.750936 2018] [proxy:warn] [pid 15151:tid 139749167687424] [client XX.X.XXX.XXX:52388] AH01144: No protocol handler was valid for the URL /ccvv. If you are using a DSO version of mod_proxy, make sure the proxy submodules are included in the configuration using LoadModule.
[Sat Apr 28 05:58:54.413674 2018] [proxy:warn] [pid 15152:tid 139749075367680] [client XXX.XXX.XXX.XXX:52052] AH01144: No protocol handler was valid for the URL /download/resources/com.atlassian.confluence.plugins.system-templates:system-template-resources/assets/images/welcome.png. If you are using a DSO version of mod_proxy, make sure the proxy submodules are included in the configuration using LoadModule., referer: http://confluence.domain.tld:8090/
[Sat Apr 28 06:06:01.545108 2018] [proxy:warn] [pid 15152:tid 139749142509312] [client XXX.XXX.XXX.XXX:56425] AH01144: No protocol handler was valid for the URL /download/resources/com.atlassian.confluence.plugins.system-templates:system-template-resources/assets/images/welcome.png. If you are using a DSO version of mod_proxy, make sure the proxy submodules are included in the configuration using LoadModule., referer: http://confluence.domain.tld:8090/
[Sat Apr 28 06:07:41.611033 2018] [proxy:warn] [pid 15151:tid 139749125723904] [client XXX.XXX.XXX.XXX:61275] AH01144: No protocol handler was valid for the URL /rest/plugins/1.0/available/recent. If you are using a DSO version of mod_proxy, make sure the proxy submodules are included in the configuration using LoadModule.
[Sat Apr 28 06:08:22.905128 2018] [proxy:warn] [pid 15151:tid 139749117331200] [client XXX.XXX.XXX.XXX:63266] AH01144: No protocol handler was valid for the URL /rest/plugins/1.0/available/recent. If you are using a DSO version of mod_proxy, make sure the proxy submodules are included in the configuration using LoadModule.
[Sat Apr 28 06:08:27.386761 2018] [proxy:warn] [pid 15152:tid 139749201258240] [client XXX.XXX.XXX.XXX:63487] AH01144: No protocol handler was valid for the URL /rest/plugins/1.0/available/recent. If you are using a DSO version of mod_proxy, make sure the proxy submodules are included in the configuration using LoadModule.
[Sat Apr 28 06:08:30.418984 2018] [proxy:warn] [pid 15152:tid 139749125723904] [client XXX.XXX.XXX.XXX:63642] AH01144: No protocol handler was valid for the URL /rest/plugins/1.0/available/recent. If you are using a DSO version of mod_proxy, make sure the proxy submodules are included in the configuration using LoadModule.
[Sat Apr 28 06:09:04.171813 2018] [proxy:warn] [pid 15152:tid 139749192865536] [client XXX.XXX.XXX.XXX:65305] AH01144: No protocol handler was valid for the URL /plugins/servlet/upm/marketplace. If you are using a DSO version of mod_proxy, make sure the proxy submodules are included in the configuration using LoadModule., referer: http://confluence.domain.tld:8090/plugins/servlet/upm/check?source=find
[Sat Apr 28 06:09:04.345142 2018] [proxy:warn] [pid 15152:tid 139749117331200] [client XXX.XXX.XXX.XXX:65304] AH01144: No protocol handler was valid for the URL /favicon.ico. If you are using a DSO version of mod_proxy, make sure the proxy submodules are included in the configuration using LoadModule., referer: http://confluence.domain.tld/plugins/servlet/upm/marketplace

There are no issues when enabling the virtualhost nor is there any issues when restarting the apache service.

And no there isn't, it's a new VPS instance with a clean apache installation. Apart from the primary domains virtualhost pointing to a web directory, the confluence subdomain is the only additional virtualhost that exists and is currently enabled

Thank you for guiding me in the correct direction, I was able to resolve the issue through the warnings given in the error logs and correcting the invalid proxy request by modifying my virtualhost configuration as follows:

    ProxyPass / http://confluence.domain.tld:8090
    ProxyPassReverse / http://confluence.domain.tld:8090

 to

    ProxyPass / http://confluence.domain.tld:8090/
    ProxyPassReverse / http://confluence.domain.tld:8090/

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Dec 18, 2018 in Confluence Cloud

Happy holidays from our team to yours!

Hi Community!  2018 was filled with changes for our team, both big and small, and we've taken a lot of time to both celebrate our wins and recognize areas of improvement. One thing that we're a...

456 views 3 18
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you