Confluence not sending mails from mail queue

We are having this issue where one of the 2 Confluence servers (that operate in a clustered environment) is not sending out mail notifications that are in its queue. The other server is sending out notifications perfectly normally. We are able to force these notifications out by clicking on "Flush Mail Queue". Any hints as to why the mails are not being automatically sent? 

We are running Confluence 5.4.4 

4 answers

0 votes

If you look at Administration > Scheduled Jobs, are you seeing one for "Flush Mail Queue"? If so, check whether is is disabled or it has next schedule in the past. You can click on "Run" to activate it and change the interval if needed.

If that is not the issue, check the logs to see if there are any errors.

Yes, there is a job called "Flush Mail queue", and it is scheduled, and is active. Its actually running every minute according to the "History". However, when I manually run it - it sends the mail. But the automatic triggers don't seem to send out the notifications. Checked the tomcat logs as well - but no errors about mails or notifications listed there. Anything else?

Anything different in the atlassian-confluence.log file? If not, have you tried a restart yet?

Tried a restart already - and am not sure if I can find the location of this atlassian-confluence.log file.. can u provide pointers to how I can find that pls?

It will be under your Conlfuence_Home/logs folder. You can find the Conlfuence Home under Administration > System Info.

Checked those logs - but couldn't find anything that pointed to any errors.

The system seems to have resolved itself since the database to which the application was pointed to, changed this last weekend - so all good now. Would still be nice to understand why this happened though..

I am having the same problem, and when I flush the mail queue is send 1 of the 100 emails.

So then I click flush again and in the logs  I get "doFlush Queue was sending - skipped mail flush this time."

Team,

       We frequently having this issue with our confluence instance? Does anyone have Idea what really causing this problem. Is there any permanent solution for this issue?

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Oct 11, 2018 in Confluence

What are your project planning tips?

Hello Community,  Jessica here from the Confluence product marketing team! Today I wanted to get your takes on project planning –– what works, what doesn’t, how do you know if you’re doing it r...

259 views 1 4
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you