Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Confluence losing the status of checkboxes

It is happening on heavily edited large pages. I tick off a task / checkbox but in a week or so it loses the tick.

What could be the cause? What to do?

2 answers

1 accepted

1 vote
Answer accepted

@Jiri Pik Did you find the cause? Having the same issue ...

Disable collaborative editing ...

i was afraid you would say that :D

I also noticed that this is primarily caused by collaborative editing:

  1. Somebody starts to edit the page. Oops that is not what he / she wanted, and clicks close. A collaborative edit draft is then kept in Confluence.
  2. Subsequently someone checks off a task next to their name in view mode.
  3. Later someone updates the page, starting from the previously created draft (which precedes the checkbox), and publishes. That someone is now unwittingly overwriting the previously checked checkbox.

The problem IMHO, is that setting a checkbox in view mode, should do the sane thing from a UX perspective (i.e., check the box on the latest published version of the page, AND check the box in the unpublished draft). This would avoid unsuspecting editors from unintentionally unchecking tasks.

This is a really big problem for our page review flows (that make use of tasks to indicate completion), and meeting / retrospective action point management. Is there any way we can get this prioritized and fixed? Ditching collaborative editing to avoid the issue really is not an option during work-from-home Covid times.

Like evsmirnov likes this
3 votes
Alison Atlassian Team Jan 28, 2020

Have you checked the page history?

Perhaps as this is a heavily trafficked page, someone is removing the checkmark by mistake.

Yes, I have checked the page history, but it is useless - it says that the checkbox was checked a month ago and unchecked today but I did not uncheck it.

The unchecking happens also on pages accessible by me. 

In any case, it would be good to expand the checkbox functionality to report its history. 

There are these errors in the console - is it relevant?

Properties of "AJS.Rte.BookmarkManager" were overwritten
namespace @ batch.js?locale=en-US:273
com.atlassian.confluence.plugins.confluence-frontend:split_vendors~moment.js?locale=en-US:5 Deprecation warning: moment.lang is deprecated. Use moment.locale instead.
Arguments: de
[1] 0: d, 1: e
Error
at Function.lang (https://mysite.com/s/a30f1fcabb7c99da97e49c0c8c8017d5-CDN/evw358/8401/8e8f74c7e2fea2df662fe8d0f5d79ff6ab016336/7.2.1/_/download/batch/com.atlassian.confluence.plugins.confluence-frontend:split_vendors~moment/com.atlassian.confluence.plugins.confluence-frontend:split_vendors~moment.js?locale=en-US:5:3400)
at https://mysite.com/s/a30f1fcabb7c99da97e49c0c8c8017d5-CDN/evw358/8401/8e8f74c7e2fea2df662fe8d0f5d79ff6ab016336/13.0.2/_/download/batch/com.atlassian.confluence.plugins.confluence-inline-tasks:date-helper-js-resources/com.atlassian.confluence.plugins.confluence-inline-tasks:date-helper-js-resources.js?locale=en-US:5:485
at https://mysite.com/s/a30f1fcabb7c99da97e49c0c8c8017d5-CDN/evw358/8401/8e8f74c7e2fea2df662fe8d0f5d79ff6ab016336/13.0.2/_/download/batch/com.atlassian.confluence.plugins.confluence-inline-tasks:date-helper-js-resources/com.atlassian.confluence.plugins.confluence-inline-tasks:date-helper-js-resources.js?locale=en-US:5:157
at https://mysite.com/s/a30f1fcabb7c99da97e49c0c8c8017d5-CDN/evw358/8401/8e8f74c7e2fea2df662fe8d0f5d79ff6ab016336/13.0.2/_/download/batch/com.atlassian.confluence.plugins.confluence-inline-tasks:date-helper-js-resources/com.atlassian.confluence.plugins.confluence-inline-tasks:date-helper-js-resources.js?locale=en-US:5:176
D @ com.atlassian.confluence.plugins.confluence-frontend:split_vendors~moment.js?locale=en-US:5
batch.js?locale=en-US:1960 DEPRECATED JS - AJS.debounce has been deprecated since 8.0.0 and will be removed in 9.0.0. Use equivalent functions from libraries like lodash / underscore instead
at https://mysite.com/s/d41d8cd98f00b204e9800998ecf8427e-CDN/evw358/8401/8e8f74c7e2fea2df662fe8d0f5d79ff6ab016336/17.2.5/_/download/batch/com.atlassian.confluence.plugins.sticky-table-headers:stickytableheaders-resources/com.atlassian.confluence.plugins.sticky-table-headers:stickytableheaders-resources.js:27:147
p @ batch.js?locale=en-US:1960
batch.js?locale=en-US:1960 DEPRECATED JS - Dialog constructor has been deprecated and will be removed in a future release. Use Dialog2 instead.
at HTMLDocument.<anonymous> (https://mysite.com/s/a30f1fcabb7c99da97e49c0c8c8017d5-CDN/evw358/8401/8e8f74c7e2fea2df662fe8d0f5d79ff6ab016336/3.9.8/_/download/batch/com.tensixtwo.conf.latexmath:editor_latexmath/com.tensixtwo.conf.latexmath:editor_latexmath.js?locale=en-US:5:8164)
p @ batch.js?locale=en-US:1960
batch.js?locale=en-US:1960 DEPRECATED JS - Dialog popup constructor has been deprecated and will be removed in a future release.
at h (https://mysite.com/s/080ab33781ad6fbcd6eb811c91bd410c-CDN/evw358/8401/8e8f74c7e2fea2df662fe8d0f5d79ff6ab016336/f08b142073ed75abbdbf91b355e73766/_/download/contextbatch/js/_super/batch.js?locale=en-US:2135:6588)

Hi @Jiri Pik !

I've tried the way @Alison suggested and it really worked. In the page history you can see all the changes including the checking/unchecking of tasklist items. You can find the one who did it :)

Yes, it sounds most appealing but on a page when only I have the right to modify it shows that I have unchecked which I did not. 

Like Grigory Salnikov likes this

Another mystery - I have pasted here a response some hours ago and it was lost.

There are some JavaScript errors:

2020-01-29_9-39-58.png

I see. To tell you the truth, I've already encountered such behavior when checkboxes mysteriously became un-checked. I tend to think it might be some kind of a bug or something to do with a browser and it definitely requires further investigation.

@Grigory Salnikov 

Thank you.

I think there are multiple factors:

  1. The JavaScript errors should be explained if they are material
  2. The link you mentioned is another problem - tasks are not saved as checked 
  3. My problem is that they are saved as checked but then they are unsaved and page history shows them as unsaved 

I am aware that this might be caused by a browser running out of memory or something else, but for now I cannot use Confluence Tasks since they are unreliable. 

Like Grigory Salnikov likes this

What is also strange is that I can't find many reports regarding this issue. Whether people don't pay attention to it or it happens not so often.

Initially - about a year ago, I thought this was all my mistake - I must have forgotten to check off the checkbox. 

But now, it's either Browser or Confluence's JavaScript. 

But Confluence's JavaScript should handle Browser's failures. 

BTW I found out why the initial submission very early this morning was lost - it has happened again:

We're sorry, but the form cannot be submitted due to an expired token. Please copy your content locally, reload the form, and submit your post again.

Some of our users are experiencing similar issues on active pages with ongoing edits /multiple checkboxes. From time to time, some checkboxes are mysteriously unchecked.

@Jiri Pik have you found a solution to this or any explanation from Atlassian?

 

Thanks.

Hi @Damian Karp 

we're having the same issue and did not solve it. Maybe you can start watching this issue, as I think its the one in the Confluence backlog that reflects the issue the most: https://jira.atlassian.com/browse/CONFSERVER-29341 Atlassian support could not help me with this issue.

 

As @Jiri Pik said above, it looks synchrony related and should go away by turning off collab editing - however, we're not at a point where we want to do that.

 

Sebastian

Hi @Sebastian Butterweck,

Thanks for your response! I agree, turning off the collaborative editing isn't the best workaround as losing it would have even bigger impact on comfort of work than these mysterious actions on checkboxes.

I have added my organization to the list of the impacted parties by the bug you quoted and started watching the ticket.
Hopefully, Atlassian will do something about it.

Thanks,
Damian

Do you also see the error messages in your log that are described in this ticket: https://jira.atlassian.com/browse/CONFSERVER-59497 ?

Atlassian just confirmed that its a bug:

 

"Hello,

Thank you very much, you found your smoking gun, so what you are facing is a bug described in CONFSERVER-59497.
Issue is very random and there is no known workaround, I would suggest monitoring bug for development as once it's fixed it will be updated.

Warm Regards,"

I am only a user of Confluence, but the unchecking of boxes is causing a problems for me.  It usually happens when I create a page with 4 or so check boxes. Once the users approve them, I edit the page and add 2 more check boxes. It is at this time the check boxes "uncheck". It happens so often that I take a screen shot of the page with the boxes checked because I expect it to happen.  And from what I read, Atlassian is not interested in the problem. I work with legal documents and getting them approved, so this error is very much a problem. I know my users and they are not unchecking the boxes, maybe if it was more random. It happens to my coworker also. We are running the latest version. I am happy to log my company as a affected also.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Confluence Cloud

🏠 Say hello to the new Confluence Home!

Hi Atlassian Community, My name is DJ Chung, and I’m a Product Manager on the Confluence Cloud team. Today, I’m excited to share a new and improved version of Home. The new Home helps you ...

38,419 views 28 126
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you