Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Confluence is vacant, a call to tenanted [public abstract org.hibernate.Session org.hibernate.Sessio

I'm installing Confluence 6.4.0 with a custom docker image that just install confluence and add postrgres 42.2.1 driver in a docker swarm. I fulfill the first steps of the installation wizard and when I put database connection string an push Next, Confluence create all the objects on Postgres but Confluence server crack with this error:

Confluence is vacant, a call to tenanted [public abstract org.hibernate.Session org.hibernate.SessionFactory.getCurrentSession() throws org.hibernate.HibernateException] is not allowed

 

Hibernate properties have not yet been persisted in confluence.cfg.xml

 

I've tried to apply this post: 

https://confluence.atlassian.com/confkb/confluence-generates-confluence-is-vacant-error-on-install-779164449.html?_ga=2.96605019.579963035.1519719218-1114388361.1517399356

but it isn't the problem. I've tried to install dfierents versions of Confluence and postgres driver, but problem persists.

I've tried to install on a Local Windows Docker Swarm and It works. 

I don't know what happend, but it seems a problem with Docker Swarm. Do you have any issue about this mistery?

Thx in advance

 

1 answer

0 votes

Hi Javi,

Could you have a look here as well? 

The hibernate properties error occurs there so it could be a permissions issue, for example, either on the home folder itself or your database.

If this does not help, are you able to provide us with the details that are occurring in your Confluence application logs? That will give us more details to the problem.

Regards,

Shannon

Hi Shannon, ths for reply.

I've tried the diferents resolutions on your link and I haven't resolt the problem. I'm deploying in a Docker Swarm, and I've read that it isn't supported by Confluence, Is it true?

Otherwise, tomorrow I'll try to review docker swarm security configuration.

The logs are the same:

Confluence is vacant, a call to tenanted [public abstract org.hibernate.Session org.hibernate.SessionFactory.getCurrentSession() throws org.hibernate.HibernateException] is not allowed

 

Hibernate properties have not yet been persisted in confluence.cfg.xml

2018-02-28 10:50:32,739 INFO [localhost-startStop-1] [com.atlassian.confluence.lifecycle] contextInitialized Starting Confluence 6.7.1 [build 7601 based on commit hash d9a7d86ddd6172b1b5a38b9e62018-02-28 10:50:36,885 WARN [localhost-startStop-1] [com.atlassian.config.ApplicationConfig] setApplicationHome Application home does not exist. Creating directory: /var/atlassian/confluence/s2018-02-28 10:50:36,893 INFO [localhost-startStop-1] [atlassian.confluence.cluster.DefaultClusterConfigurationHelper] lambda$populateExistingClusterSetupConfig$1 Populating setup configuration 2018-02-28 10:50:36,894 WARN [localhost-startStop-1] [atlassian.confluence.cluster.DefaultClusterConfigurationHelper] lambda$populateExistingClusterSetupConfig$1 Could not find shared config fi2018-02-28 10:50:39,073 INFO [localhost-startStop-1] [atlassian.plugin.manager.DefaultPluginManager] earlyStartup Plugin system earlyStartup begun                                               2018-02-28 10:50:42,329 INFO [localhost-startStop-1] [atlassian.plugin.manager.DefaultPluginManager] logTime Plugin system earlyStartup ended                                                    2018-02-28 10:50:42,332 INFO [localhost-startStop-1] [atlassian.plugin.manager.DefaultPluginManager] lateStartup Plugin system lateStartup begun                                                 2018-02-28 10:50:43,774 INFO [localhost-startStop-1] [atlassian.plugin.manager.DefaultPluginManager] logTime Plugin system lateStartup ended                                                     2018-02-28 10:50:44,594 INFO [localhost-startStop-1] [com.atlassian.confluence.lifecycle] init Confluence is ready to serve                                                                      2018-02-28 10:54:10,806 INFO [http-nio-8090-exec-1] [springframework.web.context.ContextLoader] initWebApplicationContext Root WebApplicationContext: initialization started                     2018-02-28 10:54:15,484 INFO [http-nio-8090-exec-1] [com.atlassian.confluence.lifecycle] <init> Loading EhCache cache manager                                                                    2018-02-28 10:54:35,798 INFO [http-nio-8090-exec-1] [springframework.web.context.ContextLoader] initWebApplicationContext Root WebApplicationContext: initialization completed in 24990 ms       2018-02-28 10:54:35,834 INFO [http-nio-8090-exec-1] [atlassian.plugin.manager.DefaultPluginManager] shutdown Preparing to shut down the plugin system                                            2018-02-28 10:54:35,835 INFO [http-nio-8090-exec-1] [atlassian.plugin.manager.DefaultPluginManager] shutdown Shutting down the plugin system                                                     2018-02-28 10:54:35,925 INFO [http-nio-8090-exec-1] [atlassian.plugin.manager.DefaultPluginManager] earlyStartup Plugin system earlyStartup begun                                                2018-02-28 10:54:36,070 WARN [http-nio-8090-exec-1] [osgi.container.felix.ExportsBuilder] getUrlClassPath Cannot deep scan non file 'http://felix.extensions:9/'                                  -- referer: http://10.36.64.9/setup/setupdbchoice-start.action | url: /setup/setupembeddeddb-default.action | traceId: 0077fd8cbe913288 | userName: anonymous | action: setupembeddeddb-default 2018-02-28 10:54:54,578 WARN [http-nio-8090-exec-7] [confluence.impl.vcache.SynchronousExternalCache] lambda$get$11 Failed to read entry from cache 'com.atlassian.bandana.BandanaPersister': Fai -- referer: http://10.36.64.9/setup/setupdbchoice-start.action | url: /setup/setupembeddeddb-default.action | traceId: 00e4a839cc7e9b32 | userName: anonymous                                   2018-02-28 10:54:54,596 ERROR [http-nio-8090-exec-7] [atlassian.confluence.servlet.ConfluenceServletDispatcher] sendError Could not execute action                                                -- referer: http://10.36.64.9/setup/setupdbchoice-start.action | url: /setup/setupembeddeddb-default.action | traceId: 00e4a839cc7e9b32 | userName: anonymous                                   java.util.concurrent.CompletionException: org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'tenantedTransactionManager' defined in class path resource [dat        at java.util.concurrent.CompletableFuture.encodeThrowable(CompletableFuture.java:273)                                                                                                            at java.util.concurrent.CompletableFuture.completeThrowable(CompletableFuture.java:280)                                                                                                          at java.util.concurrent.CompletableFuture.uniHandle(CompletableFuture.java:824)                                                                                                                  at java.util.concurrent.CompletableFuture.uniHandleStage(CompletableFuture.java:834)                                                                                                             at java.util.concurrent.CompletableFuture.handle(CompletableFuture.java:2155)                                                                                                                    at java.util.concurrent.CompletableFuture.handle(CompletableFuture.java:110)                                                                                                                     at com.atlassian.confluence.impl.concurrency.CompletionStageUtils.foldResult(CompletionStageUtils.java:19)                                                                                       at com.atlassian.confluence.impl.vcache.SynchronousExternalCache.get(SynchronousExternalCache.java:236)                                                                                          at com.atlassian.confluence.setup.bandana.ConfluenceCachingBandanaPersister.retrieve(ConfluenceCachingBandanaPersister.java:78)                                                                  at com.atlassian.confluence.setup.bandana.ConfluenceCachingBandanaPersister.retrieve(ConfluenceCachingBandanaPersister.java:71)                                                                  at com.atlassian.bandana.DefaultBandanaManager.getValue(DefaultBandanaManager.java:32)                                                                                                           at com.atlassian.bandana.DefaultBandanaManager.getValue(DefaultBandanaManager.java:24)                                                                                                           at com.atlassian.confluence.setup.settings.DefaultDarkFeaturesManager.getSiteEnabledFeatures(DefaultDarkFeaturesManager.java:60)                                                                 at com.atlassian.confluence.setup.settings.DefaultDarkFeaturesManager.getDarkFeaturesAllUsers(DefaultDarkFeaturesManager.java:81)                                                                at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)                                                                                                                                   at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)                                                                                                                 at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)                                                                                                         at java.lang.reflect.Method.invoke(Method.java:498)                                                                                                                                              at org.springframework.aop.support.AopUtils.invokeJoinpointUsingReflection(AopUtils.java:302)                                                                                                    at org.springframework.aop.framework.JdkDynamicAopProxy.invoke(JdkDynamicAopProxy.java:202)                                                                                                      at com.sun.proxy.$Proxy156.getDarkFeaturesAllUsers(Unknown Source)                                                                                                                               at com.atlassian.confluence.util.profiling.ConfluenceProfilingStrategy.isEnabled(ConfluenceProfilingStrategy.java:62)                                                                            at com.atlassian.util.profiling.UtilTimerStack.push(UtilTimerStack.java:50)

Javi,

I'm not aware of that exactly and wasn't able to find any details on it, so I tried to look through our support tickets to see if anyone had tried it before.

I was able to find one, but then I discovered it's actually your open ticket with our support team.

My recommendation is that we leave this on the Support ticket since they're able to get your full logs and do more of a deep investigation into the problem.

Once the issue is resolved, you can comment here in a new answer with the resolution, and I can accept it for you.

Regards,

Shannon

Ok thx Shannon

How did you go with this in the end? I've got the same issue, would love to hear your resolution as I've double checked DB connection details are correct both in server.xml and confluence.cfg.xml.

Hi Tim,

I'm reviewing Javi's ticket, and it appears that the configuration is unsupported, so we weren't able to help further at this time.

The engineer mentioned that running Confluence as a service in a swarm is not a supported configuration.

Here are the steps that were suggested to troubleshoot:

Check out this knowledge base article. I know it does not specifically related to Docker but the underlying OS is still going to be Linux so we can work though the steps. In particular, I would be interested to check these points from the 'Causes' section:

  1. The user running Confluence does not have write permissions to the home folder defined in <install>/confluence/WEB-INF/classes/confluence-init.properties or the install directory.
  2. You are running Confluence as the root user or if you have an application firewall enabled (SeLinux or AppArmor).
  3. The database driver is not located in the <install>/confluence/WEB-INF/lib folder or you are using a database version that is incompatible with the bundled driver.
  4. The Confluence database is not configured correctly with permissions - the owner needs to have 'can login', 'can create databases' and 'can create roles' assigned to it.
  5. The file confluence.cfg.xml is corrupt

This community post also has some additional steps which seem to mirror the KB.

However, even with those steps in mind we were not able to successfully set up Confluence in this way, which further shows that perhaps this configuration is completely unsupported by Confluence.

If you're able to get it to work please feel free to share your experience here.

Regards,

Shannon

Hi Shannon

I've got the same issue,My Server is CentOS7.4,  MySQL5.7,Confluence 6.10.1

Exception:

Caused by: com.atlassian.confluence.tenant.VacantException: Confluence is vacant, a call to tenanted [public abstract org.hibernate.Session org.hibernate.SessionFactory.getCurrentSession() throws org.hibernate.HibernateException] is not allowed.
at com.atlassian.confluence.tenant.TenantGate$1.lambda$create$0(TenantGate.java:43)
at org.springframework.aop.framework.ReflectiveMethodInvocation.proceed(ReflectiveMethodInvocation.java:179)
at org.springframework.aop.framework.JdkDynamicAopProxy.invoke(JdkDynamicAopProxy.java:208)
at com.sun.proxy.$Proxy150.getCurrentSession(Unknown Source)
at sun.reflect.GeneratedMethodAccessor267.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:498)
at org.springframework.aop.support.AopUtils.invokeJoinpointUsingReflection(AopUtils.java:302)
at org.springframework.aop.framework.JdkDynamicAopProxy.invoke(JdkDynamicAopProxy.java:202)
at com.sun.proxy.$Proxy150.getCurrentSession(Unknown Source)
at org.springframework.orm.hibernate5.HibernateTemplate.doExecute(HibernateTemplate.java:344)
at org.springframework.orm.hibernate5.HibernateTemplate.execute(HibernateTemplate.java:313)
at com.atlassian.confluence.setup.bandana.persistence.dao.hibernate.HibernateConfluenceBandanaRecordDao.getRecord(HibernateConfluenceBandanaRecordDao.java:39)
at com.atlassian.confluence.setup.bandana.ConfluenceDaoBandanaPersister.retrieve(ConfluenceDaoBandanaPersister.java:29)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:498)
at org.springframework.aop.support.AopUtils.invokeJoinpointUsingReflection(AopUtils.java:302)
at org.springframework.aop.framework.ReflectiveMethodInvocation.invokeJoinpoint(ReflectiveMethodInvocation.java:190)
at org.springframework.aop.framework.ReflectiveMethodInvocation.proceed(ReflectiveMethodInvocation.java:157)
at org.springframework.transaction.interceptor.TransactionInterceptor$1.proceedWithInvocation(TransactionInterceptor.java:99)
at org.springframework.transaction.interceptor.TransactionAspectSupport.invokeWithinTransaction(TransactionAspectSupport.java:281)
at org.springframework.transaction.interceptor.TransactionInterceptor.invoke(TransactionInterceptor.java:96)
at org.springframework.aop.framework.ReflectiveMethodInvocation.proceed(ReflectiveMethodInvocation.java:179)
at org.springframework.aop.framework.JdkDynamicAopProxy.invoke(JdkDynamicAopProxy.java:208)
at com.sun.proxy.$Proxy151.retrieve(Unknown Source)
at com.atlassian.confluence.setup.bandana.ConfluenceCachingBandanaPersister.lambda$retrieve$0(ConfluenceCachingBandanaPersister.java:80)
at com.atlassian.confluence.impl.vcache.SynchronousExternalCache.lambda$get$11(SynchronousExternalCache.java:239)
at com.atlassian.confluence.impl.concurrency.CompletionStageUtils.lambda$foldResult$0(CompletionStageUtils.java:19)
at java.util.concurrent.CompletableFuture.uniHandle(CompletableFuture.java:822)
... 113 more

Like Raquel Rodríguez likes this

Hi @周超,

I would recommend for this that you either raise a support ticket so we can obtain specific details about your server or raise a new question.

The reason being is that this thread was related to Docker and database incompatibility which doesn't appear to be related to your case, although the error is the same.

When you raise the case or a new question be sure to include information about when this last worked, if it was an upgrade, etc.

Thank you!

Shannon

Hi Shannon

OK,TKS

wind

Did you get anywhere with this, as I think I have the same issue.  I installed the trial, all went OK up until I pasted the licence in and now all I get is this.  Doesn't fill me with confidence and reminds me that I hate Java with a passion you can only dream of.  The logs are completely unintelligible and contain so much nose it drowns out any useful information buried within.

Damien Tan Atlassian Team Oct 16, 2018

Hey @Richard Hall this might be a bit late but if you've encountered the "Confluence is vacant, a call to tenanted" issue during the installation, it can sometimes be an issue with the database so I'd say it is good to first isolate whether if the issue is coming from the server or the database by installing a fresh new Confluence with the embedded database that is meant for evaluation only.

if installing with the embedded database went well, then we've basically isolated the issue is coming from the database rather than the server (eg: file permission, localhost host not found, etc..)

then our next step will be to setup the database according to the documentation (but i need to know which database you're using)

 

in the case if the setup wizard failed even before you can select the embedded database, perhaps you can try to delete all of the installation files and download it again just to make sure we're not affected by any corrupted files there. Else it will be good to open a support ticket with us and let us help you out from there!

Thought I'd pipe up with my solution.

We were presented with the same symptoms when trying to deploy a Kubernetes workload.

The issue was that the default nginx timeout for the ingress is set to 60 seconds, which isn't enough time for Confluence to create the database schema. Thus, the ingress was timing out, halting the installation step (this is immediately after keying in the licence and pressing "Next"), and borking the setup half way through.

Increasing the nginx read timeout for the ingress fixed things.

This also helped a similar issue when trying to restore from a (largeish) XML backup.

Hope this helps someone.

Like jason_zeng likes this

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Posted in Confluence

What do you think is the most *delightful* Confluence feature? Comment for a prize!

- Create your own custom emoji 🔥 - "Shake for Feedback" on mobile 📱 - An endless supply of GIFs via GIPHY 🤩 Is there anything quite as nice as a pleasant surprise? Comment below with what...

335 views 23 8
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you