It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Confluence Goes back to intial setup after exiting Docker Edited

Hi Everyone,

At first I have Confluence, JIRA and MySQL database hosted separately on different Docker container.

I finished setting up confluence and was able to link it with JIRA and everything seems to work perfectly so I closed Docker and turned off the machine (my PC).

The next day, I started Docker and MySQL & Confluence Containers then when I tried to access Confluence I went back to initial setup.

My issue is similar to the link below, but issue closed as answered but I don't think it did.

https://community.atlassian.com/t5/Confluence-questions/When-I-restart-quot-atlassian-confluence-server-quot-docker/qaq-p/1172621

Now I am not sure what to do now and how to fix it? Why did it work in the first place then after container restart it stopped?

Also, setting up confluence is like a flip coin. I had to do the setup (including remove image/container) almost 3 times before it worked for some bootstrap issue but this another story/issue.

Thanks for help,

2 answers

In my experience, the Confluence always does an initial setup if the confluence.cfg.xml file does not exist or cannot be read (rights problem)

Thank you,

But what kind of permission I need to set? I can't find anything about that .

Please check whether this is available after a restart.

After Docker restart, it overwrite the whole folder.

So what I did is I made a copy of confluence.cfg.xml inside the same folder and restarted docker. So all previous files (after setting up confluence) were deleted and replaced with fresh setup files.

I also compared permission to file after I finished setting up Confluence and after Docker restart, and all have the same file permission.

 

After Conf. Setup: -rw-r----- 1 confluence confluence 5762 Apr 18 13:31 confluence.cfg.xml

After Docker Restart: -rw-r----- 1 confluence confluence 3706 Apr 18 13:38 confluence.cfg.xml

But how does it look like the content of confluence.cfg.xml changed after the Docker restart?
Because the file sizes are different!

Please check the content!

Please also check whether the file ... /WEB-INF/classes/confluence-init.properties is retained. The path to the data storage is defined here.

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
SERVER
VERSION
7.3.5
TAGS
Community showcase
Posted in Confluence

Lessons and Learnings: Six Months of Working Remote [Discussion]

Hey there, folks! For most of us, the past six months- yes, you read that right- have been a journey. More people than ever before have pivoted to working remotely, and navigating being on-scre...

3,138 views 4 6
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you