Confluence 6 won't start editor

When I install fresh copy of Confluence 6.0.1 and create space, I can't add enything else becouse editor won't load. When i clik on 'Create' button I get red hint 'Loading the editor's taking longer than usual. Give it a few moments, then refresh your page if it still doesn't load. Speak to your Confluence admin if that doesn't fix it'.

When I first time install Confluence it was with free licence and H2 databse everithing works fine. Then I purchace licence and install fresh copy on new VPS with Mysql 5.6. OS is Centos 7 x64 with 8Gb ram.

I try almost everthing with no success. Reinstall Confluence few times with restore old data and without restore.

Also I do the same for JIRA and everthing works fine.

After recheck all premissions on folders and database I dont have a clue what to check next. Logs don't show any errors.

 

Any suggestion ?

Dragan

4 answers

1 accepted

As I expect, solution was in configuration. I installed JIRA first and use it as user manager for Confluence, So when i enable option 'External user management' in Security Configuration of Confluence everything works fine.

 

I just installed Confluence (Linux Ubuntu 16.10) and created my first space, the editor however doesn't load and a message is displayed:

"Loading the editor's taking longer than usual. Give it a few moments, then refresh your page if it still doesn't load. Speak to your Confluence admin if that doesn't fix it."

I suppose that is what happened to you too? I also had installed JIRA Software first and then Confluence, with JIRA managing users and groups, I enabled the option also in Confluence "external user management" - but still the same issue. sad

RIP Confluence, I guess

I had the same problem and the solution was to deactivate the new collaborative editing feature that seems to be swallowed by some firewalls. If you do not need the feature, go to Admin --> General Configuration --> Collaborative Editing and deactivate it. If you need the features, look at the following page on how to fix it: https://answers.atlassian.com/questions/43893571

It is the collaborative editing. You should be able to make it to work with e.g. these proxy settings:

ProxyPass /synchrony-proxy http://localhost:8090/synchrony-proxy

<Location /synchrony-proxy>
Require all granted
RewriteEngine on
RewriteCond %{HTTP:UPGRADE} ^WebSocket$ [NC]
RewriteCond %{HTTP:CONNECTION} Upgrade$ [NC]
RewriteRule .* ws://localhost:8090%{REQUEST_URI} [P]
</Location>

This works even when you use ajp-proxy for everything else.

 

After updating to Confluence 6.2.3, I had to go into General Configuration --> Administration --> Collaborative Editing and change Editing Mode to Off in order for users to edit any page.

Definately a problem with Collaborative editing and the use of Synchrony.

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Kesha Thillainayagam
Posted Friday in Confluence

We want to hear how your non-technical teams are using Confluence!

Hi Community! Kesha (kay-sha) from the Confluence marketing team here! Can you share stories with us on how your non-technical (think Marketing, Sales, HR, legal, etc.) teams are using Confluen...

274 views 11 10
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you