Cant download my Server licenses

Hi,

I just purchased a server license for Jira Software, Jira Service Desk and Confluence. When I am in my account and try to download the Server Version my Browser responds with: "ERR_TOO_MANY_REDIRECTS".

This happens with Chrome, Firefox, Edge and Internet Explorer.

We switched off the company Firewall and my colleagues tryed it aswell. Everyone gets this message.

Since is purchased the "Starter" i cant get direct support from Atlassian (what a construct...).

I hope someone can help me!

2 answers

1 accepted

0 vote

Hi Chris,

I have not been able to recreate this problem of being unable to download these installation packages.  I even tried this over my own LTE network connection using a Verizon Cell provider here in the US.  In both cases, I was able to download these files without any of these errors.

It is not clear to me why your network connections might be experiencing this kind of reply.  While I am interested to try to troubleshoot this further to understand your environment, I also thought that perhaps we can work-around this problem by using another technique.

I was able to download these binary packages for all the products I saw your account had licenses for (Jira Software, Jira Service Desk, and Confluence).  I then uploaded these to my own Google Drive account and shared these tar.gz binary files.   Could you try to download these from this other link instead?

https://drive.google.com/drive/folders/1zMo8Lwd_IAxjAiivFJlnX0nCThlS8dwk

Back to the idea of troubleshooting this download problem.  Could you please try to run the following command in a terminal/command prompt and let me know the results:

traceroute product-downloads.atlassian.com

In turn this should be able to tell us more about your specific network route that your request has to follow in order to be able to download these packages from one of our download mirrors.

Regards,

Andy

Hi Andy,

the google drive download works without a problem. Thanks for that.

Somehow I have the feeling it has something to do with"https://de.atlassian.com" since you are from the US and Shannon from the netherlands you probably get redirected on something different.

This is the result of the CMD:

Routenverfolgung zu d145e4fdyl6drh.cloudfront.net [54.192.201.188]
über maximal 30 Hops:

1 <1 ms <1 ms <1 ms

 

Different question apart from that:

When i get my Server-ID for the License am I able to reinstall Jira on a new server or is it bound to that server? In the next months we will have new servers where we would like to install Jira than.

Best regards

Chris

You only need the server id when you first want to generate the license key for the first time.  The license is not bound to that install or that specific machine.  So yes you can use that license on a different install later. 

Technically I believe the license agreement states that you cannot use the same license key simultaneously on two installs.   However Atlassian is not trying to make installations/migrations/upgrades more difficult than they need to be, so I would not expect you to have any problem with this.

You might also consider creating evaluation licenses for this first test installation.  Since it sounds like you might only use this first installation for a month that might work out since the evaluation licenses have a 30 day expiration window.   You can actually create these on https://my.atlassian.com


As for the traceroute results, mine resolve to the same hostname, but a different IP address. 

$ traceroute product-downloads.atlassian.com
traceroute to d145e4fdyl6drh.cloudfront.net (54.192.193.158), 64 hops max, 52 byte packets
 1  172.20.32.1 (172.20.32.1)  4.074 ms  4.767 ms  3.762 ms
 2  * atx-net-fw01 (172.20.248.1)  53.383 ms  1.235 ms
 3  ae1-2313.austtxasw001.aggr01.austtx.grandecom.net (72.48.156.241)  2.417 ms  2.056 ms  57.863 ms
 4  xe-0-0-3.0.core01.smrctx.grandecom.net (24.155.121.119)  3.285 ms  3.556 ms  3.737 ms
 5  24-155-121-0.static.grandenetworks.net (24.155.121.0)  9.372 ms  9.267 ms  145.773 ms
 6  52.95.217.96 (52.95.217.96)  13.271 ms  10.052 ms  9.201 ms
 7  176.32.125.176 (176.32.125.176)  161.013 ms
    176.32.125.212 (176.32.125.212)  50.937 ms
    176.32.125.140 (176.32.125.140)  49.581 ms
 8  176.32.125.245 (176.32.125.245)  40.962 ms
    176.32.125.181 (176.32.125.181)  38.638 ms
    176.32.125.217 (176.32.125.217)  39.997 ms
 9  54.239.46.16 (54.239.46.16)  44.621 ms
    54.239.46.10 (54.239.46.10)  42.583 ms  43.275 ms
10  54.239.43.176 (54.239.43.176)  39.310 ms
    54.239.43.174 (54.239.43.174)  38.692 ms  39.164 ms
11  * * *
12  205.251.245.129 (205.251.245.129)  61.122 ms  167.749 ms  39.200 ms
13  * * *
14  * * *
15  * * *
16  * * *
17  * * *
18  * * *
19  * * *
20  * * *
21  * * *
22  * * *
23  * * *
24  * * *
25  * * *
26  * * *
27  * * *
28  * * *
29  * * *
30  * * *
31  * * *

I suspect that is due to the region I am in, but I will look to create an internal ticket with one of our product teams to see if they can further investigate if this might be a region specific problem with the mirror you are being directed to.   Sorry this is a problem still, but thanks for letting us know and thanks for sharing these results.

Hi Andy,

Thats good to know than we will start the installation tomorrow. Thanks for your response and the help aswell for the download links on google drive! 

You're welcome!

Best regards
Chris

0 vote

Hi Chris,

Don't worry, we have Atlassian support staff on-hand to assist with Community issues as well so you will find you can get the same support here.

A few questions first about your situation:

  1. Are you also running behind a Proxy, and is that switched off as well?
  2. Is there a current whitelist?
  3. Is your user directory the internal one, or LDAP? If LDAP, when you switch off incremental synchronization, does the issue persist?

Thank you for the information you can provide.

Regards,

Shannon

Hi Shannon,

thanks for your response. We tried it outside of our company network and aswell with a proxy in the USA and neither works.

From my point of view it looks like a problem on your side.

Best regards,
Chris

Apologies, Chris. I thought you had installed the server version already and were receiving that error when you try to access Jira, which is another common issue.

Can you let me which version of the Server download you were trying to access? I want to test it for you but I'll need to know the URL you were accessing.

Regards,

Shannon

No problem!

It doesn't matter if i try to download Jira Software or Service Desk or Confluence. I get the same error with each link for example:

https://de.atlassian.com/software/jira/download?_ga=2.81103826.454858879.1513065652-1554153573.1513065652

 

Best regards
Chris

Chris,

Thank you for clarifying.

It's very odd; I've tested this on my home computer outside of the Atlassian network and I also do not receive the error.

If you also try from this page, do you have the same error?

Jira Download Archives

Lastly, I understand you tested without the firewall and proxy but if you were to test on a non-company computer completely outside of your company network can you reproduce the error?

You can also have Developer Tools > Network tab open and it might give us more information about what is causing this.

Regards,

Shannon

Hi Shannon,

That link does not work either. Yes i have tested it on a non-company computer completely outside of our company network. I tested it with a mobile device via LTE aswell and get the same error.

Under Developer Tool > Network nothing happens but 3 png images

image.png

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Kesha Thillainayagam
Posted Apr 13, 2018 in Confluence

We want to hear how your non-technical teams are using Confluence!

Hi Community! Kesha (kay-sha) from the Confluence marketing team here! Can you share stories with us on how your non-technical (think Marketing, Sales, HR, legal, etc.) teams are using Confluen...

2,788 views 26 10
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you