When installing the PocketQuery plugin an exception is thrown with the following message "Error retrieving dependency of class: de.scandio.confluence.plugins.pocketquery.extractors.PocketQueryResultExtractor. Missing class: org/apache/lucene/index/IndexableField".
I don't know Lucene at all (apart that it is a search engine library for Apache) and wanted to know if someone knows some causes for this error (apart from the obvious).
Seems like the plugin is not compatible with the Lucene version you have running on Confluence.
Confluence upgraded the Lucene version on Confluence 5.2: https://confluence.atlassian.com/display/DOC/Confluence+5.2+Upgrade+Notes.
So, as Felix said, double check if you're installing a version of PocketQuery that is compatible with your version of Confluence.
Actually, PocketQuery version 1.12 could only be installed on recent Confluence installations (>= 5.2). I fixed this backwards compatibility issue. There is now a version 1.12.1 that is compatible with all Confluence versions >= 4.0. Please check it out at the marketplace :)
Hi my Community friends! For those who don't know me, I'm a product marketer on the Confluence Cloud team - nice to meet you! For those of you who do, you know that I've been all up in your Co...
Connect with like-minded Atlassian users at free events near you!Find a group
Connect with like-minded Atlassian users at free events near you!
Unfortunately there are no AUG chapters near you at the moment.Start an AUG
You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs