Cannot add new users to confluence-admin

confluence-admin is a group that is in the Confluence built-in directory, and I am trying to add users to that directory, but I cannot.

We have Active Driectory for our user directory.

So, the order of user directories is:

* Our AD Server

* Confluence Builtin Directory

When i try to add a user to the confluence-admin group, nothing happens. I suspect that this is because Confluence is trying to update that group in Active Directory, which does not exist there, but cant update the Confluence local dir.

What tdo I need to do to allow adding users to the confluence-admin group?

Thanks.

4 answers

Does the user you're trying to add definitely have an email address defined? This could be the blocker. Also suggest checking your log file for signs of an issue at the time you add the user to the group.

Here's what I forgot: The users that I am trying to add to confluene-admin are part of our domain. That is probably the problem.

Is there a way to make a group in our domain that has the same super powers as confluence-admin in the local confluence directory?

Even if the user is a domain user, not a built-in user account, you should still be able to add them to the admin group. I doubt very much that you have a group called confluence-administrators in your domain, so there should be no clash or confusion there. Also, the order of user directories is unlikely to be the problem in my opinion. Can the user you want to add actually login to Confluence okay? I'd check that first.

Everyone can login just fine. But I cannot add new users to the confluence-admin group I think that this is because the directory that holds it does not know anything about the users in our AD Domain, so when I try to add a user from there, the add just fails.

I do not get an error messge, I just dont see the user added to the list.

Thanks.

Hi David,

Did you get a resolution to this? I have the same configuration and same problem. I previously added users to our confluence-administrtators group but now that I have AD added as a user directory in JIRA I cannot add anyone to the confluence-administrators group.


Steve Blevins

ACR

Hi David,

Could you please double check if the user directories configured is currently set to have "Read Only, with Local Group" permission.

With this permission, you should be able to access your "confluence-administrators" group from "Manage Group" menu and try to add the users from there.

Hope it helps.

Cheers,
Septa Cahyadiputra

Also if @CharlesH [Free spirit] already noted that it is possibly not the directory order, give it a try and switch the order. The docs say

Changes to users and groups will be made only in the first directory where the application has permission to make changes.

https://confluence.atlassian.com/display/DOC/Managing+Multiple+Directories

Hey Septa Cahyadiputra ,

Your suggestion worked like a charm for me. thanks a lot.

Thanks,

Sreekar.

Hey Septa Cahyadiputra ,

Your suggestion worked like a charm for me. thanks a lot.

Thanks,

Sreekar.

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Kesha Thillainayagam
Posted Apr 13, 2018 in Confluence

We want to hear how your non-technical teams are using Confluence!

Hi Community! Kesha (kay-sha) from the Confluence marketing team here! Can you share stories with us on how your non-technical (think Marketing, Sales, HR, legal, etc.) teams are using Confluen...

2,694 views 26 10
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you