Cannot access any Confluence page after upgrade to Confluence 4.0

I recently upgraded from Confluence 3.5.11 to Confluence 4.0. Now, whenever I try to access any page in any of the sapces (Even the Demonstration Space) I get an error saying:

Page Not Found

The page you were trying to reach could not be found. This could be because:

  • The page does not exist.
  • The page exists, but you do not have permission to view it.

I know that it isn't a permissions issue because I am logged in as an Administrator. I can still see all the most recent updates and everything on the right and all my spaces still show up ,they just can't be accesses. I tried Manually Building the page index, but that didn't resolve the issue. I also tried altering the base URL because the port changed from 8080 to 8090 with the upgrade but that also did not resolve the issue.

I have done the upgrade many times in many different ways (Manually vs. Installer) and still no luck. I always end of having to revert to the old version of Confluence to access the pages again. I already have a support ticket filed with Atlassin about they haven't been able to resolve it as yet. Has anyone encountered something similar?

3 answers

1 accepted

Accepted Answer
0 votes

I was looking through the logs and I found that it was a plugin that was causing all my problems. The 'Page Approval Plugin' was causing everything to mess up for some reason. Here is the relevant log section:

url: /display/TSGDev/Home | userName: raward
java.lang.NoSuchMethodError: com.atlassian.confluence.core.ContentEntityObject.getContent()Ljava/lang/String;
at net.customware.confluence.plugin.pageapproval.PageApprovalSpaceViewPageAction.execute(PageApprovalSpaceViewPageAction.java:58)

I disabled that plugin and now it works!

Hopefully we have already gotten everything resolved for you via the support ticket.

If you are still stuck: 1) my appoligies for the delay and 2) Can you post your ticket number so I can follow up?

Thanks. This is my ticket number :CSP-74768. They are in the process of looking through the latest logs to try to find the problem.

https://support.atlassian.com/browse/CSP-74768

That issue sounds like it was quite the headache...glad to see it is resolved this morning. If we can be of any further help, please let us know.

Hi, I have the same symptoms with my version of Confluence 4.1.2. A completely new install on OS X Lion. Where can I find the solution to this or at least compare notes?

Thanks.

I'm not sure if you can access the JIRA ticket but it is located here https://support.atlassian.com/browse/CSP-74768

My problem was a plugin that was installed before the upgrade that was causing loads of problems. The 'Page Approval Plugin' was causing the render issues. I disabled that plugin (and also uninstalled it later) and I was able to get the pages to display.

Another thing to try is this: http://confluence.atlassian.com/display/DOC/Wiki+Markup+to+XHTML+Migration

These solutions all revolve around upgrades to existing installs though so your problem may be elsewhere

Thanks Rondal. Unfortunately I don't have permission to view the JIRA ticket. Looking at my log files, it seems the rendering is falling over for the Spaces Directory Plugin. Disabled that but nothing.

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Tuesday in Confluence

Introducing Praecipio Consulting, an Atlassian Solution Partner

Hey there Community!  My name is Vannya Vallejo, the Channel Communication Specialist at Atlassian and I want to help Atlassian users like you learn about our Solution Partners and how they c...

328 views 0 9
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you