Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
Community Members
Community Events
Community Groups

Can't add user to restricted page

I want to add user Sebas Wijnen to a restricted page. This page may only been seen by him or me. I'm the sys admin. It contains the passwords for our production server.

The users aren't loaded for the selection, but the user is known within Confluence. We also user Jira and BitBucket. Jira manages the user roles.

Why aren't the users displayed? Jira and Confluence use OAuth and are connected.

Screen Shot 2017-08-22 at 14.34.17.pngScreen Shot 2017-08-22 at 14.35.41.png

6 answers

Wow, over a year later, and this issue is still happening. We are using Jira version 8.7.1 and Confluence Version7.3.2 and we have exactly the same issue. Trying to add specific users to restricted spaces, they just don't appear in the search drop down:

Confluence Broke.png

Yet the user exists under Confluence User Management, and has logged items in Jira:

Confluence Broke_02.png

Anyone got an answer to this yet - I tried the add / remove groups trick someone mentioned but it didn't seem to let me add a group, I could only remove and re-add.

This apparently still happens on occasion.  I figured out how to fix it.  This is a classic windows trick - re-saving the properties.

Go to user management - edit the users groups, add the user to an arbitrary group and press save then remove user from arbitrary group and save.  (you may be able to simply edit groups and press save to fix)

You should be good to go now.


This trick worked for me too! Thanks

I submitted a ticket to my urban development helpdesk and was told that the reason I wasn't able to add my user was because he wasn't added to the confluence users group in crowd directory. The helpdesk admin had to add the user. Once the user was added to crowd, I was able to add the user to restricted pages.

Hi Team,

We need to add user to a restricted page, but the users are not loading in, when am trying to add them. We have recently upgraded confluence to 7.0.1 from 6.2.4

jira version -8.4.1

Screenshot 2019-09-30 at 15.04.08.png

Could you please us fix this issue.

0 votes
Thomas Schlegel Community Leader Aug 22, 2017

Hi Chris,

maybe Sebas has no viewing permission on the space itself?

Hi Thomas,

Thanks for your quick response.

There are no restrictions on the space itself. This is btw the only page with restrictions.

I doesn't show any other users.

I use Confluence 6.3.3, and Jira 7.4.2. So both the latest versions.


Thomas Schlegel Community Leader Aug 22, 2017

have you you tried searching for  "swi" (the username).

Thomas Schlegel Community Leader Aug 22, 2017

if your space is public, maybe Sebas doesn't have the role "confluence-users" ?

I've tried "swi", same result, no users.

And just double checked, he is in the group "confluence-users"

are you able to load any other user? Do you see an error in the logfiles?

are you able to add him to the permission scheme of your space?

I did manage to load some other users, but not all.

The permission schemes I use is the default one. The default that's shipped with the installer.

No error in the logfiles.

This is the API call:


Response (HTTP 200 response):


Thomas Schlegel Community Leader Aug 22, 2017

@Nic Brough _Adaptavist_ @Stephen Deutsch @Shannon S  or anyone else:

Do you have any other idea what is going wrong here?

Screenshot of the Global Permissions and the Application for the complete picture.

Screen Shot 2017-08-22 at 16.29.11.pngScreen Shot 2017-08-22 at 16.29.30.png

Thomas Schlegel Community Leader Aug 22, 2017

could you please also post a screenshot of the permissions on the space?

This is happening to me too - I am unable to add permission to a specific user, I receive an error "There was an error submitting the page restrictions. Please try again later." 

Please fix!


has anyone found a solution to this problem?

Hi Bartek,

In my case is was solved in one of the updates. We're currently running 6.9.0 in which it works.

Maybe upgrading also works for you?


Suggest an answer

Log in or Sign up to answer
Community showcase
Published in Confluence

Confluence: Where work and wellness meet

Feeling overwhelmed by the demands of work and life? With a 25% increase in the prevalence of anxiety and depression worldwide during the pandemic, for most of us, it’s a resounding yes . 🙋‍♀️ ...

753 views 5 21
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you