It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Can't add a page property macro in a new template page Edited

Hi,

New to index pages but created a successful trial example with new pages - with a page property macro inserted and then created the index page.

ALL good there.

So decided to go to the next level and create a new template page for users to create a new page from that template which will be listed on the index page.

I can create the new template page with the content and layout I want but for some reason I can't add a page property macro section to it so it shows in the index page... Why??? when I can add that macro to a new page but not in the template.

When I call the macro with { it gives me the list of macros and I select the page property one then save... but nothing happens... ?

Gilbert

 

As a temp solution I create the page property macro in a normal page ... copy and paste it in the template page...

1 answer

0 votes

Hello @Gilbert Louis,

That's weird, I do have Page properties macros on templates I've created:

existingtemplate.PNG

But when I create a new template and add a Page properties macro, I reproduce your issue: nothing happens, the macro isn't added to the page. Looking at my browser console, I get a 404 error:

https://mysitename.atlassian.net/wiki/rest/tinymce/1/macro/placeholder 404

So it looks like a bug - have you created a support ticket yet? I'll create one on my side.

Hope this helps!

- Manon

Hi @Manon Soubies-Camyno I didn't create a jira for this issue but I since found another related thread here

https://community.atlassian.com/t5/Confluence-questions/Confluence-Page-Templates-amp-Macros/qaq-p/963719

which has a jira created. So I voted for it.

Interestingly it has the same workaround so looks like I'm not the only one with this issue

Like Manon Soubies-Camy likes this

Thanks for the update @Gilbert Louis - I've also voted for this issue.

Try creating a test page and place the macros you need on the test page... go into view source and copy the source markup.  Then create a template and go into view source and paste the source you copied.  Save the template and you should be fine.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Posted in Confluence

How is your team having fun and bonding, remotely, utilizing Confluence?

Thanks everyone for answering last week’s question. The winner of the random drawing from those who commented is: @LarryBrock I’ll contact you separately with your prize details. This wee...

306 views 9 7
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you