It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Bug with table of contents for Chrome Edited

Hello, everyone!

There seems to be a bug with TOC macro for Google Chrome Version 80.0.3987.122 (Official Build) (64-bit)).
There is no jumping to a created anchors, unfortunately.
The problem seems to affect all the pages that are using TOC macro.
Could someone check if the problem happens with your space as well?
I have tried to Google the report to Atlassian but alas there is none.

Thank you in advance!

4 answers

We found out that chromes implementation of smooth scrolling (in combination with Confluence Release 7) seems to be part of the problem. When I disable smooth scrolling via chrome://flags/#smooth-scrolling, the problem seems to disappear after restarting Chrome. It is interesting that the problem does not occur in old Confluence releases (e.g. 6.13).

We are using 7.4 server, our issue only appears in ToC pages that contain a table.

I can remove the smooth scrolling, but we have circa 1.5K daily users. I cant ask them all to do this

we have the same situation with thousands of chrome clients with smooth scrollign enabled... so i created an Atlassian support issue now (no reply so far / not yet published).

@Marco Leist is there any update ? I have also created a ticket in Mar20 with Atlassian but its still in "Gathering Impact". There is also Problem with 6.X Versions and also did not work by disabling smooth scrolling in chrome and restarting Chrome. 

 

Thanks,

Preeti

Unfortunately no solution so far.
Here is the link to the public ticket: https://jira.atlassian.com/browse/CONFSERVER-60200
It certainly helps if as many people as possible vote up the ticket and watch it.
Thanks, Marco

FYI: In https://jira.atlassian.com/browse/CONFSERVER-60200 someone provided a CSS Fix - my first tests (i inserted it into custom HTML) were successfull! Here the fix:

html { scroll-behavior: unset;}  

It works with Edge to add more info :)

I have the exact same issue which brought me here to your question. Verified in Chrome that the TOC links jump past the Heading text. When visiting the TOC link in IE it correctly jumps to the Heading text.

I have seen the same issue

This seems to only happen in Chrome and if the page contains a table. The anchor goes to the first table in the page

If you remove all tables it works fine

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Posted in Confluence

Lessons and Learnings: Six Months of Working Remote [Discussion]

Hey there, folks! For most of us, the past six months- yes, you read that right- have been a journey. More people than ever before have pivoted to working remotely, and navigating being on-scre...

8,531 views 6 6
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you