Attachments missing when migrating confluence to another server

I am using Server 2012 R2 and am trying to migrate Confluence 5.10.3 to a new server. I have followed the instructions to move confluence home and install folders along with the database, but it does not work. Only sees bits and pieces of info. I then try the xml backup and then import into the same version of confluence on the new server, and when I go to check the spaces, they are missing a lot of attachments in the spaces. I am not sure what else I can try. I have tried doing xml backups with and without attachments and then manually dumping the attachments folder into the new server and doing a rebuild of the index from scratch with no luck.

I have followed the following sites to try and get my data imported and neither of these worked.

https://confluence.atlassian.com/confkb/how-to-resolve-missing-attachments-in-confluence-201761.html

https://confluence.atlassian.com/doc/migrating-confluence-between-servers-184150.html

1 answer

This widget could not be displayed.

Hi Phil

Are you performing a full re-index after the migration?

Thanks

Bhushan

 

 

 

Yeah, tried that, and still no luck.

Are you changing OS or Databases? If you could quickly summarize the steps in detail I can try and help. If not, please create a support ticket.

Nope, same OS and same postgresql database. I have tried numerous steps

 

  1. I followed the instructions in the confluence support to do an install of the same version of Confluence 5.10.3 and same version database pg admin 1.18.1 and I update all the database and install links to point to the directories to the correct locations, and when I go to check confluence, it shows as if it is still a brand new install, but on the home page it shows that changes have been made from anonymous users.
  2. I tried doing an XML backup (both with attachments and without attachments) from the old confluence to the new confluence then a content re-index and it shows all the spaces, but it is missing a lot of the attachments that users uploaded.
  3. I have also tried although I know this is not the correct way of doing it, doing an xml backup from 5.10.3 to 6.0.1 with no luck as well.

 

Phil,

I suggest the below steps if it is a Confluence Server - Confluence Server migration and the source system is not very large (you are able to create an XML backup).

  1. Create a new database. Install the same version of Confluence on target system ie. 5.10.3 and connect it to the new database.
  2. Install all the add-ons on the target instance to match the add-ons installed on source.
  3. Create an XML backup from source and restore on target system.
  4. Move the attachments folder from source to target home folder.
  5. Perform full re-index.

Let me know how that goes.

Thanks

Bhushan

 

Tried that as well with the same result. The attachment folder is very large at over 50GB

Sorry about that. Please create a support ticket at support.atlassian.com.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Sep 17, 2018 in Confluence

Why start from scratch? Introducing four new templates for Confluence Cloud

Hi my Community friends!  For those who don't know me, I'm a product marketer on the Confluence Cloud team - nice to meet you! For those of you who do, you know that I've been all up in your Co...

596 views 7 6
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you