Attachment version history isn't displayed

after upgrade confluence to 3.5.13, the attachment screen (under tools) isn't displayed attachment version history.

I used "edit in office" link to edit the document and after saved the document, no attachment version history can be displayed, there is no icon for me to hide or unhide the version history.

Any help? Thanks

3 answers

1 accepted

0 votes
Answer accepted

Sherry, I am experiencing the same thing you are in Firefox (10.0.2) and IE (8 with compatibility view). However, I can see the arrow and can toggle it open to see past versions in Chrome (17.0.963.56) and IE (8 without compatibility view). You might see if a different browser helps.

However, in those two browsers that show the toggle, the icons are messed up. You can actually see a down arrow, a right arrow, a trash can, a pencil, and a gear. (see screenshot attached) They all function as the toggle to show attachment versions... they don't actually edit, delete, etc. Maybe the developers were planning a UI enhancement that didn't get finished. But that's a small concern for me - I was simply glad to see that I could view the previous versions.

Thanks a lot! I tried google Chrome and it works.

When viewing a list of attachments, a new version of an existing attachment can be added simply by uploading an attachment with the same filename on the attachment view. Click the blue arrow next to an attachment to display previous versions of the attachment.

Existing files will be kept with the name 'Version x', where the value of 'x' increments with each upload of an attachment with the same filename.

For details you may refer here: http://confluence.atlassian.com/display/CONF35/Attachment+Versions

thanks for your information. My problem is - after uploading an attachment with the same filename or using "edit in office" link and saved the document, there is no blue arrow next to the attachment as expected.

Is this a bug in confluence?

Hi there,

Im experiencing the same issue. Im using the attachment macro on a page. Altough I have multiple versions of one document the macro only shows the newest one. I can see the + symbol, but when click on it, the macro wont show me a version tree..

I have tested multiple browsers on both Windows and Mac.. and updated all my plugins, software etc.. is this a bug? When I go to the normale attachment overview



Hi Jere,

My problem is with browser, so it is a bug. If you have tried on different browsers and all displayed the same, I think you may need to check the macro on the page. You may refer to the details of attachment macro below, include parameter OLD to display history of the attachment:

http://confluence.atlassian.com/display/CONF27/Displaying+List+of+Attachments+in+a+Page

hope this help you.

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Mar 12, 2019 in Confluence

Confluence Admin Certification now $150 for Community Members

More and more people are building their careers with Atlassian, and we want you to be at the front of this wave! Important Dates Start the Certification Prep Course by 2 April 2019 Take your e...

1,040 views 2 13
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you