It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Anchor links do not work

Using confluence is so simple and easy. But, I have been having a nightmarish time trying to get Anchor work for me. I am using "Confluence 1000.0.0-66d80941701".

On a page, say, "https://<>.com/myspace/main page/sub page/my page1", I created an anchor with the name bottom. (please note the spaces in my URL).

On another page, say, "https://<>.com/myspace/main page/my page2", I created a link using Advanced tab selection, and pointed to anchor my page1#bottom.

I Published both pages. Clicking on the link NEVER takes me to the anchor location. Always takes me to top of the page in "https://<>.com/myspace/main page/sub page/my page1"

I followed the example https://community.atlassian.com/t5/Confluence-questions/Insert-an-Anchor/qaq-p/1013116 ... but it doesnt work!

Need this to be resolved ASAP for me to create a bi-directional traceability in the spec I am writing. Kindly help!

5 answers

1 accepted

1 vote
Answer accepted

Hi Madhav,

how have you configured the link to your anchor on the other page? From what you wrote I assume both pages are in the same space. By entering the page name as it is (with spaces) and adding the anchor name you can make it work. I just tested it again because I like to use this feature as well. So just add on the advanced tab: "page name with spaces#anchorname" without quotation marks and please let me know if it works for you :) If not, please add a screenshot of the link configuration, the anchor name, and page title so we can build the link together.

Best,

Max

Yes, I am working in the same confluence space.

I just now created sample / dummy pages with page names containing spaces, and having sub pages within. I created an anchor inside one of the sub pages and a link in one of the top pages.  I am able to navigate and it works. (I did not include draw.io images in this experiment!)

Unfortunately, when I do the same on my main confluence spec (which includes draw.io images), I am always getting redirected to top of the page. 

One thing I found out thru this exercise is I am using draw.io plugin for drawing images in confluence. And I just now found that draw.io plugin is playing spoilsport. When my anchor on the page is way down below, and I have a fairly large draw.io image on top of the page, the image load re-positions the view to the top of the page! As a result, Anchor gets overridden!

So, I attribute the functional misbehaviour of Anchor in Confluence to the presence of a draw.io image in the page.

Without draw.io image, the anchor is working like a charm!

I will have to accept your answer. Create a new ticket with draw.io plugin issue.

Thanks for your time, Max! You are indeed the community champion!

Don't make me blush! You're welcome. But your findings are interesting. I will keep an eye out and test some other embedded contents and how they interact with anchors. And hopefully, there will be a fix soon for your specific issue!

We have noticed similar issues: clicking a hyperlink in a draw.io figure jumps to the wrong place on the same page. Not totally off, just too far down. Sometimes it works better, sometime worse.

Hi everyone- I was able to solve the issue today

Create anchor at the location you want it to direct to:

Add Anchor Marco 

Anchor Name #testname

 

then insert link using any page in your sapce

 

Link: Page name##testname

Link Text: Test Name

 

the double hashtag did it for me.

 

hope this helps

Hi am having similar problems ... :(

I want to be able to email a link to a specific anchor on a specific page

As far as I can tell I have used the right formatting as follows

Anchor name is    UNTICK

Page name is      1 Quick Start Guide

Space Key is        CORES

https://groups.org/display/CORES/1+Quick+Start+Guide/#1QuickStartGuide-UNTICK

When I email that link to myself, when I click the link in the email it takes me to the correct page but not to the Anchor point, just the top of the page.

I am currently using Sever 5.8.16 but we will soon be upgrading to 6.15

Hi Rodney,

that doesn't look right for me. Could you try:

https://groups.org/display/CORES/1+Quick+Start+Guide#1QuickStartGuide-UNTICK

Best, Max

Thanks Max

tried that ... that also open the right page but doesn't skip down to the Anchor point

I have spotted some other references that indicate that linking to an anchor from outside the Confluence instance has a bug and doesn't work.

https://jira.atlassian.com/browse/CONFCLOUD-62501

Any updates on that? I have the same issue

I have the same problem. I don't think Anchors work.

The URL I'm trying to make work is:

https://confluence.MyCOmpanyDomain.com/confluence/display/DCPH/Test%3A+Word1+Word2+Word3#myanchor

I tried defining my anchor as both #myanchor and myanchor (in case the octothorp is required in the coding, unlike using the traditional <a .... > tag in HTML.  In both cases, when I use my anchor in the URL, it goes to the top of the page, not the anchor.

 

The HTML snippet in my page source code is:

<td>
<div class="content-wrapper">
<p>
<span style="color: rgb(0,51,102);"> <span style="color: rgb(0,51,102);"> <ac:structured-macro ac:macro-id="30a27554-999c-45f7-a2fc-ed47f53b34ab" ac:name="anchor" ac:schema-version="1">
<ac:parameter ac:name="">#myanchor</ac:parameter>
</ac:structured-macro>Text for myanchor</span> </span>
</p>
<p>
<span style="color: rgb(0,51,102);"> <span style="color: rgb(0,51,102);">[ OCS ]<br/> </span> </span>
</p>
</div>
</td>

Confluence Cloud claims some sort of fix https://jira.atlassian.com/browse/CONFCLOUD-62589 

Pending response on Confluence Server https://jira.atlassian.com/browse/CONFSERVER-58628

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Posted in Confluence

How is your team having fun and bonding, remotely, utilizing Confluence?

Thanks everyone for answering last week’s question. The winner of the random drawing from those who commented is: @LarryBrock I’ll contact you separately with your prize details. This wee...

283 views 9 7
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you