It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

All images are dropped from imported Word documents

We just upgraded to Confluence 4.2.1 and suddenly we can no longer import Word documents properly. It worked in Confluence 4.1.7.

Is there a new setting in Confluence 4.2.1 or is it just broken?

Thanks,

Jens

6 answers

Same issue on a fresh install. Platform is CentOS 6 x64.

Is it working for anybody?

Could somebody please confirm that this is not working for anyone on 4.2.1? We are completely stuck... Thanks!

I found a workaround. It still works when the word document gets converted from .docx (2010) to .doc (2003).

This is really confusing because it previously worked just fine with Office 2010...

Didn't see this before and just posted the same question: https://answers.atlassian.com/questions/52151/when-importing-word-document-images-fail-to-import-attach-and-display

I lodged this with support 2 weeks ago, and they were unable to reproduce so i thought it was just me. I evaluated version 4.1.7 and it was working. My first production install was 4.1.9 which this functionality was broken and i lodged the support call, they were unable to solve or reproduce. I have since completed another fresh install, this time using the zip package for windows instead of one-click install. Same result.

I was about to try a linux distro so you saved me time - thanks.

One way we found as a possible work around is to create a new page, attach the word document manually, and then use the 'office word' macro to display the contents.

The tech mentioned that the office macro has changed (renamed) since on a recent released, so i imagine that they've managed to break the 'import word doc' feature as part of this change. :)

Good to hear that I am not the only one. :)

You can always try my workaround above. Just convert the Word 2010 document to a Word 2003 document using "Save as" and changing the file type. It somewhat works. Minus some formatting loss, but I guess there is always loss during the conversion anyhow...

Hopefully, there will be a fix for us soon.

Thanks for replying to me!

This is indeed a new bug in Confluence (starting 4.1.9 or higher) that only affects .DOCX documents. I've just filed a bug here at: https://jira.atlassian.com/browse/CONF-25477 . The workaround currently is to convert the .DOCX document to .DOC format as suggested by JST68 above.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Posted in Confluence

Lessons and Learnings: Six Months of Working Remote [Discussion]

Hey there, folks! For most of us, the past six months- yes, you read that right- have been a journey. More people than ever before have pivoted to working remotely, and navigating being on-scre...

4,120 views 4 6
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you