Ad hoc Canvas: Restarting Plugin License Storage plugin

Hello, actually i'm testing confluence and ad hoc canvas. Yesterday everything works fine but now i get this (german) errormessage on top of every adhoc-list:

Sorry, die Operation kann nicht ausgeführt werden. Bitte sicherstellen, dass das Plugin License Storage plugin installiert und aktiviert ist. Ein Neustart des Plugins sollte den Fehler beheben.

My english translation ;) : Sorry the opration couldn't be executed. Please make sure that the plugin Plugin License Storage plugin is installed and activated. A restart of the Plugin should eliminate the error/problem.

All modules (97) of adhoc-canvas are active. I found these four adhoc-modules:

adhocLicenseManager (licenseManager)
Adhoc Canvas License (comalatech.adhoclists.checklist.global.license)
thirdPartyPluginLicenseStorageManager
pluginLicenseStoragePluginInstaller

Can someone tell me how i can fix the problem or even restart these plugins? I have tested to reinstall adhoc-canvas but nothing happend.

Since this error is shown, the list are shown, but i can't edit them or even create new subpages. When i try to edit a list, all content from the page is deleted and only the adhoc-list is displayed.

Actually i have a guilty 30-day-trial-license (27 Days left).

4 answers

1 accepted

This widget could not be displayed.

All,

the problem is related to an incompatibility in the plugin license management API.

An updated version of Ad hoc Canvas will be released asap. Pls check https://marketplace.atlassian.com/plugins/com.comalatech.adhoccanvas for updates.

Thanks

This widget could not be displayed.

We didn't have this problem when we installed adhoc canvas initially (yesterday), but we upgraded to Confluence 4.2.4 today and we're getting the same message (in English...) above any embedded adhoc canvas items:

Sorry, but we cannot find the required licensing support to execute the requested operation. Please ensure that the Plugin License Storage plugin is installed and enabled. Restarting this plugin should resolve the problem.

A review of the Confluence logs shows this exception (I changed the hostname and username)

2012-05-28 18:29:44,826 ERROR [http-8086-2] [confluence.adhoclists.license.DefaultAdhocLicenseManager] getLicenseStatus

-- referer: http://ourhostname/dashboard.action | url: /display/Hosting/Migration+progress+chart | userName: myusername | action: viewpage | page: 5865612

java.lang.ClassCastException: com.atlassian.upm.license.internal.impl.PluginLicenseManagerImpl cannot be cast to com.atlassian.upm.api.license.PluginLicenseManager

at com.atlassian.upm.license.storage.lib.PluginLicenseManagerAccessorImpl.getPluginLicenseManager(PluginLicenseManagerAccessorImpl.java:34)

at com.atlassian.upm.license.storage.lib.ManagerAccessor.getLicenseManager(ManagerAccessor.java:68)

at com.atlassian.upm.license.storage.lib.ThirdPartyPluginLicenseStorageManagerImpl.getLicenseManager(ThirdPartyPluginLicenseStorageManagerImpl.java:148)

at com.atlassian.upm.license.storage.lib.ThirdPartyPluginLicenseStorageManagerImpl.getLicense(ThirdPartyPluginLicenseStorageManagerImpl.java:38)

at com.comalatech.confluence.adhoclists.license.DefaultAdhocLicenseManager.getLicenseStatus(DefaultAdhocLicenseManager.java:49)

at com.comalatech.confluence.adhoclists.license.DefaultAdhocLicenseManager.getCachedLicenseStatus(DefaultAdhocLicenseManager.java:141)

at com.comalatech.confluence.adhoclists.license.DefaultAdhocLicenseManager.isLicensed(DefaultAdhocLicenseManager.java:38)

at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)

at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)

at java.lang.reflect.Method.invoke(Method.java:597)

at org.apache.velocity.runtime.parser.node.PropertyExecutor.execute(PropertyExecutor.java:142)

at org.apache.velocity.util.introspection.UberspectImpl$VelGetterImpl.invoke(UberspectImpl.java:533)

at org.apache.velocity.runtime.parser.node.ASTIdentifier.execute(ASTIdentifier.java:198)

at org.apache.velocity.runtime.parser.node.ASTReference.execute(ASTReference.java:262)

at org.apache.velocity.runtime.parser.node.ASTReference.evaluate(ASTReference.java:470)

at org.apache.velocity.runtime.parser.node.ASTExpression.evaluate(ASTExpression.java:62)

at org.apache.velocity.runtime.parser.node.ASTIfStatement.render(ASTIfStatement.java:85)

We tried restarting the plugin licence storage plugin but this changed nothing.

We tried re-applying our adhoc canvas licence key but this changed nothing.

Hope this helps the Comalatech guys solve the issue :)

Ahh the update! You are right i have updated it per "Update all" too ;) Deinstall 1.0.3 and install 1.0.2 of Ad hoc Canvas takes no effect.

This widget could not be displayed.

Thanks - we are looking at this right now.

Best, M.

This widget could not be displayed.

Can you try restarting Confluence for us? Thanks, Martin.

Restarting confluence takes no effect.

A couple of points:

  1. What version of the UPM (Under System Plugins) is running?
    1. Does it show an upgrade available for the UPM?
    2. Make sure all the modules for the UPM are enabled
  2. We have tested on a clean, new install of 4.2.4 - this does work - the problem is dependent on upgrades (in Cameron's case from 4.1.x)

Thanks, M.

Sorry but i can only find:

1.: Plugin Licensing Manager Plugin 0.6.1 Adaptavist.com Ltd Aktiviert (activated)

1.1.: Only an update for Balsamiq Mockups is available (don't know why the update fails)

1.2.: Plugin-Module verwalten - 11 von 11 Modulen aktiviert (activated).

But i think its the wrong one.

For Ad hoc canvas:

Ad hoc Canvas 1.0.3 and no updates available.

Plugin-Module verwalten - 96 von 97 Modulen aktiviert. The only one which ist deactivet is:

Editor Content Ad hoc Resources (editor-contentresources) Enable this module if you want embedded board/lists markup to be hidden in the Editor. (Users using IE8 browser will alway see the markup)

Which plugin do you mean with: UPM?

1.: Plugin Licensing Manager Plugin 0.6.1 Adaptavist.com Ltd Aktiviert (activated)

1.1.: Only an update for Balsamiq Mockups is available (don't know why the update fails)

1.2.: Plugin-Module verwalten - 11 von 11 Modulen aktiviert (activated).

2.: It seems so :/

Look for Atlassian Universal Plugin Manager Plugin - it should appear Plugins -> Upgrade if its out of date.

You can see the version number anyhow by going to Plugins -> Manage Existing

Then, under System Plugins at the bottom of the page (you'll have to "Show System Plugins").

Thanks, Martin.

Ah i'm sorry now i got it ;)

Atlassian Universal Plugin Manager Plugin 2.0.5 and all Modules are activated

Atlassian Universal Plugin Manager - Plugin License Storage plugin 2.2.4 and all Modules are activated

No updates available

I have diasabled UPM - Plugin License Storage plugin, restartet confluence and activated the plugin again but it has no effect.

Hi - we note that "Atlassian Universal Plugin Manager - Plugin License Storage plugin" does not exist on our fresh install of Confluence 4.2.4. Can you please disable it, restart and see if this makes any difference?

Thanks, Martin

Deactivated UPM - PLSp: no effect

Restarted Confl.: no effect

Activated UPM - PLSp: no effect

My Confluence Version is 4.2.2!!!

:( Okay - thanks - we're discussing again.

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Published yesterday in Confluence

Add-on evaluation with confluence templates

Atlassian market place contains number of Apps/Addons which improves the capability of out of the box Atlassian products. It is good to follow a plugin evaluation process before install add-ons. So t...

33 views 5 3
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you