Activity Stream Gadget Fail

@Atlassian

I'm running Confluence 5.4.3 download and tyring to set up the Activity Stream Gadget but am having major problems with it.

I've checked the latest documentation but that seems to be out of date and doesn't describe the gadget in its current form.

I'm finding two main problems, which I'll describe in reverse order:

  1. After setting up the macro and saving, if you then try to edit it, you can't. There is no way of editing anything you initially set up. If you click on the Filter link all that happens is that the content that is already showing is greyed out. To change anything, you have to delete the macro and start again. I can't believe this is the way it was designed as not being able to change filter settings whenever you want to would be very poor design.
  2. I've had to set this macro up several times now, so feel pretty sure I know what's going on with it. For example, when I initially started using it, I was able to set it up for both Confluence and JIRA. However, now I can only set it up for Confluence: there is no Jira option. In between these two states, there was a moment when the macro allowed not only Jira and Confluence, but also Bonfire, Bamboo and others as possible activity streams (as selectable tick boxes). Because of this I was able to set up one version of the macro for Jira. However, no matter what I do now, there is NO Jira option from the Filter link or the Add button. Not only that, when I try to add the macro from scratch (i.e. no options or params have been set) it is automatically showing the update details that I set up when I first started trying to work with this macro. So it's remembering the details of an earlier instance of the macro - how is that possible?

So the macro is unpredicatable and seems not to be working properly. Is anyone else having issue with this?

Cheers.

1 answer

Mick,

We had similar issues but it was caused by SSL configuration and we got those fixed once SSL configuration issues were resolved.

Mehmet,

Thanks, I'll get our tech team to look into it.

It is now displaying both the Jira and Confluence options but doesn't seem to be acting as I think it should, mainly because the info it's returning is either null or not what I'd expect. It's also some distance from what's in the documentation.

What did you do to the configs that made this work properly?

Cheers.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Oct 24, 2018 in Confluence

Atlassian Research opportunity with Confluence templates

Do you use templates with Confluence? Take part in a remote 1-hr workshop. You'll receive USD $100 for your time!   We're looking for people to participate in a   remote 1-hr workshop...

1,102 views 17 14
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you