Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,465,095
Community Members
 
Community Events
176
Community Groups

How to make make Confluence pages public?

Hello

I would like to my make my Confluence space public so EVERYONE can see it (read access) without being logged in. I once set that and thought it works. Now I got a complaint it doesn't work. I logged out at Confluence and tried the main link. Oh, it really doesn't work! 

forbidden.png

So I checked my settings in Confluence:

Settings -> Global Permissions :

global.png

First checkbox "Use Confluence" is checked (for anonymous access)

 

Settings -> Space Permissions :

space.png

Looks good to me too: Anonymous access granted "show"

 

What am I doing wrong? Is there any place I have to check a box?

 

Regards

7 comments

Brant Schroeder Community Leader Oct 10, 2018

From you screenshots anonymous access is configured correctly in confluence.  If a user tries to access a page in Confluence that is not anonymous and they are not logged in then they should be directed to the login page.  The 403 forbidden page should not be showing so it seems like something else is happening.  Have you checked your logs? This is the only thing I was able to find that Atalssian has posted on the issue, maybe this is the same thing that is happening to you https://jira.atlassian.com/browse/JSDSERVER-5726

Thank you for the answer and also for the link! In my case it's different: I'm not having the issue with any mobile devices (as stated in the link). Maybe too (not yet tested). I'm having this issue on my notebook. Furthermore I try to access my page directly by link, no Jira involved.

Feel free to test it: Testlink

Do you get the permission error too?

I get this error only when I'm not logged in to Atlassian (= anonymous). 

Regards

Brant Schroeder Community Leader Oct 10, 2018

Nope it is good for me.  Wondering if it is an issue with cookies.  Have you tried clearing your cache?

Hmm, that is weird! I've just tested it again (being logged out = anonymous) and it worked! (without clearing the cache). Sometimes I clear my cache maybe that caused the hiccups.

I have to ask some others to test it.

Brant Schroeder Community Leader Oct 10, 2018

the navigation breaks on the sub-pages.Capture6.PNGCapture7.PNG

Brant Schroeder Community Leader Oct 10, 2018

Looks like it might have something to do with your instance.  I would raise a support ticket with Atlassian.

Ok, tnx, I will with link to this thread!

I'm not allowed to create a bug: User 'tyfash' doesn't have the 'Assign Issues' permission

Tnx, just was there!

Comment

Log in or Sign up to comment
TAGS

Atlassian Community Events