Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
Community Members
Community Events
Community Groups

Add a sort button on a table in confluence

I created a table with 100 rows. On the first column there is number from 1 to 100. I need to sort the table directly in confluence with the first column.


Hi @Alexandre Richard

a button (or more small arrows) are added directly when you create a table to every column.

It works perfect. But pay attention you can not use the sort function when editing. And it won't be sorted permanently - when you come back to the side it will be shown without sort.

@Fabienne Gerhard Please move "to every column" after "are added" and remove "directly". Thank you!

Like Jacob Hansen likes this

If you need to sort when editing or to set a permanent sorting, then you can use Table Filter macro.

Like # people like this

Tables should be sortable if the first row is a header row ... it won't work if it is just a normal row with a background color and bolded. You need to make sure to use the header row button for tables in the editor tool bar.


I created 2 similar pages containing tables with header row and the sorting worked perfectly fine. Until it didn't work anymore on one of the mentioned pages. I can't figure out why (I've checked the history and it didn't help me at all); I've tried to use the button for header creation several times, but nothing changes.


For another page, created yesterday, that header sorting doesn't work either and I can't change this. However, I tried to create another table now and the sorting seems to work just fine.


Could you please help me out with this?




Hi Iulia,

It might be an idea to check if your tables contain any merge cells since merged cells in a table prevent the table for being sortable.




Very helpful! The one created yesterday has some merged cells for sure.

On the other hand, I don't remember doing any merges in the other table, but I'll check it out anyways.


Yeah, merged cells will turn it off. So, will having multiple header rows. I think having a header column as well will turn it off. So, it has to be a very vanilla table ... nothing fancy.


I've made the table again, though no merges were found... At first, it seemed to be working, but at some point, it just didn't work anymore.

The table includes all kind of Macros- among them, Excerpt Include brings me a summary from other pages (where an excerpt is being used), and some of those excerpts have tables, pictures and graphics inside them. Could any of these elements affect the table property?

It's really frustrating, because it used to work, even with excerpts having tables inside. I believe that only the graphics are a new addition (I'll test this assumption).

If anyone has another workaround idea, it would be really helpful. This summary page really helps me keep track of the news on many projects, but I really need to sort them based on date.


Kind regards!


Like # people like this

I've experienced the same problem. It works one day and doesn't the next (without any changes made to the page).

Looking for solution with new editing option. Have a new table, nothing fancy, and can not sort table. Hmm. Just made a table, with header row, and a few lines underneath and no luck. Hmmm any solutions with the new confluence editing on cloud?

Like # people like this

Just created a table, with a header row, but it doesn't have sort buttons. 

Does having links in some cells prevent this feature from working? 

I'm having the same issue. Checked back on my old pages and they all have sort OK.  Just the ones created with the new editor.

Like # people like this

Also having the same issue.  Any resolution yet?

Like # people like this

Same issue here 

After creating a table in the old editor , the sort functionality works perfectly but not using the new editor . Perhaps a bug to be resolved by the Atlassian developers

Like Timothy Ling likes this

I just noticed that if you use an excerpt-include on an excerpt that has a table the sort function does not appear in the excerpt-include version.  Note that the sort function in this case does work fine on the original content containing the excerpt.

Is this:

  • expected behaviour? 
  • a bug?
  • unknown?



Like Timothy Ling likes this

Being able to sort with merged rows should be an option.  Is there a way to request this?  Why do we have to resort to grade school tables to get this feature?

Like Matteo Pacenti likes this

This feature worked perfectly before, and now suddenly stopped (even for a newborn table with a header row and simple cells not merged). 

Anything from atlassian updates?

Like # people like this


Log in or Sign up to comment

Atlassian Community Events