Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,463,390
Community Members
 
Community Events
176
Community Groups

server.port in bitbucket.properties has no effect

Trying to setup Bitbucket Server behind an IIS reverse proxy and running into some trouble. I've updated my bitbucket.properties file with "server.port=8443" per the instructions here:

https://confluence.atlassian.com/bitbucketserver/secure-bitbucket-with-tomcat-using-ssl-776640127.html

But when I run start-bitbucket.bat to test, I see "starting server on port 7990."

Why is the server.port setting having no effect?

 

Bitbucket Server 6.2.0

1 answer

0 votes

Hi @Bob Rzadzki ,

first of all check if you're managing bitbucket.properties file in the correct path BITBUCKET_HOME_FOLDER/shared/bitbucket.properties (read here)

Please verify that you correctly restarted the application. 

For a reverse proxy configuration I know that there are two different ports, one for the application and one for the reverse proxy.

Here an example of my current configuration :

server.port=7990
server.context-path=/bitbucket

server.proxy-name=YOUR_PROXY_NAME_EXAMPLE_mydomain.com
server.proxy-port=8443
server.scheme=https
server.secure=true

Hope this helps,

Fabio

Hi Fabio, thanks for your help.

The "find your home directory" link in the page you sent is dead, unfortunately. I am editing the bitbucket.properties file in the directory referred to in set-bitbucket-home.bat; that should be the right one, correct?

I tried the config you provided, with my proxy's hostname, and there's no change in the behavior.

Fabio, I had to iterate through some other options but it's working now. Thank you for your help, that got me on the right track.

I'm happy for that @Bob Rzadzki !

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events