"This is not a valid source path / URL" when connecting directly from Bitbucket

A colleague set up a repository on Bitbucket and invited me to join. I've never used Bitbucket before, but registered and was able to view the project pages and source.

I followed the link to download SourceTree (on Windows 7 Ultimate x64 SP1), went through the setup wizard, and installed the internal Git and Mercurial packages. Now I'm clicking the SourceTree link directly in the Bitbucket page, but SourceTree states ""This is not a valid source path / URL" in the clone repository dialogue. There is a "Details" button next to the message, which simply produces an empty dialogue box.

This also happens if I browse in the "Hosted Repositories" dialogue. How can the path be invalid, if it's directly produced by the Bitbucket website or the SourceTree browsing process? What do I do next?

10 answers

1 accepted

Thanks for the reply. Although not strictly a version issue, the first link provided some help. When SourceTree started for the first time, I skipped setting up Git & Mercurial in the wizard. Then I reran the wizard and chose to download and install the embedded packages. But it seems installing those didn't actually enable them - in the Tools -> Options dialogue they were both disabled! Enabling Mercurial allowed the clone dialogue to correctly identify the repo.

Shouldn't they have been enabled after installing the embedded packages through the wizard?

I couldn't agree more. Specially when there is no instruction to tell you to enable it. This should be done automatically or at least the help icon should tell you to check this.

Thanks, in my case i had external git so I switch to 'use system git' - version of git shows up, dialog "this is not valid source path" disapear and finally i can clone repo.

Thank you for your reply!!
I updated both embedded stuff (Mercurial and Git) and it finally worked!! :-)

Thanks again and have a great day y'all ;-) B-)

I have solved this one on Win 7 by going to

Tools -> Options -> Mercurial -> Update Embedded Mercurial


We had also same issue "This is not a valid source path / URL "and it got resolved by updating the Embedded Git of Source Tree.

Steps to resolve:


Open source tree, Tools -> Options -> Click on Git Tab -> Update Embedded Git.

 

 

Hai Jagdish , 

i was a newbieee at using the source tree and bitbucket , followed ur solution it worked perfectly fine .

thanks for the info .

Updating Embedded Git worked for me after restarting Source Tree, thanks

I had the same issue "This is not a valid source path / URL "and it got resolved by updating the Embedded Git of Source Tree. I also got an error when trying to push (third party error ... setup password and username... to many failed password attempts...) and this solved that too.

Steps
Open source tree, Tools -> Options -> Click on Git Tab -> Update Embedded Git.

Worked for me.
Thanks

Hey Andrew,

I've filed an issue on JAC here for you: https://jira.atlassian.com/browse/SRCTREEWIN-1316

The problem seems to be that neither the VCS required not being installed / utilised by SourceTree leads to a completely empty error message. We could be more helpful and say that a Git/Hg install couldn't be found with further help on how to set them up (i.e. "Would you like to set Git/Hg up now?") and take them through that process again.

Cheers

Thanks Kieran. Filling in the error box would definitely help - users just need to be prompted to enable the embedded plugins if they've installed but not enabled them.

you probably made a mistake in the password verify your account

After setting everything to Embedded Git. I was still getting the same error, to solve this, I just ran the software as admin. 

i am also having same error pls help

For me it was version conflict between the GIT Client & GIT-System-Installation , I ended up using the Embedded GIT (instead of System GIT), which resolved the issue.

 

To do so go to: Tools -> Options -> Git (tab) -> "Use Embedded Git" button.

 

HTH

Works for me. Thanks.

I just got this issue checking out SourceTree for a collegue (usually just use cmd line git). Kind of an embarrassing way to start things off!

Try Embedded Git.

My issue was that I had cygwin installed and the path was set so that cygwin binaries would execute first. The invalid path contained `/cydrive/c/` which should tell you why the invalid path occurred. Not sure if SourceTree needs to use explicit paths all throughout when it is not using Embedded Git. 

I'm reluctant to use SourceTree with all the usability issues and bugs, but I must since we have Bitbucket Server as our repository. :(

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Posted Jun 12, 2018 in Bitbucket

Do you use any Atlassian products for your personal projects?

After spinning my wheels trying to get organized enough to write a book for National Novel Writing Month (NaNoWriMo) I took my affinity for Atlassian products from my work life and decided to tr...

29,191 views 26 12
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you