It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

"This is not a valid source path / URL" when connecting directly from Bitbucket

Andrew McDonald Nov 11, 2013

A colleague set up a repository on Bitbucket and invited me to join. I've never used Bitbucket before, but registered and was able to view the project pages and source.

I followed the link to download SourceTree (on Windows 7 Ultimate x64 SP1), went through the setup wizard, and installed the internal Git and Mercurial packages. Now I'm clicking the SourceTree link directly in the Bitbucket page, but SourceTree states ""This is not a valid source path / URL" in the clone repository dialogue. There is a "Details" button next to the message, which simply produces an empty dialogue box.

This also happens if I browse in the "Hosted Repositories" dialogue. How can the path be invalid, if it's directly produced by the Bitbucket website or the SourceTree browsing process? What do I do next?

16 answers

1 accepted

83 votes
Answer accepted
Andrew McDonald Nov 13, 2013

Thanks for the reply. Although not strictly a version issue, the first link provided some help. When SourceTree started for the first time, I skipped setting up Git & Mercurial in the wizard. Then I reran the wizard and chose to download and install the embedded packages. But it seems installing those didn't actually enable them - in the Tools -> Options dialogue they were both disabled! Enabling Mercurial allowed the clone dialogue to correctly identify the repo.

Shouldn't they have been enabled after installing the embedded packages through the wizard?

Gordon Kam Dec 11, 2013

I couldn't agree more. Specially when there is no instruction to tell you to enable it. This should be done automatically or at least the help icon should tell you to check this.

Like Janie zhu likes this
marcin Apr 07, 2016

Thanks, in my case i had external git so I switch to 'use system git' - version of git shows up, dialog "this is not valid source path" disapear and finally i can clone repo.

Like # people like this
Nico Hunink Jun 05, 2018 • edited

Thank you for your reply!!
I updated both embedded stuff (Mercurial and Git) and it finally worked!! :-)

Thanks again and have a great day y'all ;-) B-)

Sarah Belhumeur Aug 26, 2018

Does anyone have an answer for this for Mac users that don't have a "Tools" option in the menu bar?

Like Angela Wallace likes this
Montgomery Young Sep 19, 2018

I have SourceTree 2.6.10. I got the same error message. Based on the information in this thread, I went into Options/Git/Git Version and downloaded an embedded version. This fixed the problem for me.

Angela Wallace I'm New Here May 13, 2019

@Sarah Belhumeur I'm sure you've found this by now, but for anyone else with a Mac, go to

  • Sourcetree > Preferences > Git > Git Version
  • Click "Use System Git" (via @marcin 's response above)

At this point I was prompted to enter my system password twice to update my keychain password, and then this fixed the issue for me and I was able to pull code.

11 votes
Federico Caramelli Jan 17, 2014

I have solved this one on Win 7 by going to

Tools -> Options -> Mercurial -> Update Embedded Mercurial


8 votes
B Jagdish Mar 31, 2016

We had also same issue "This is not a valid source path / URL "and it got resolved by updating the Embedded Git of Source Tree.

Steps to resolve:


Open source tree, Tools -> Options -> Click on Git Tab -> Update Embedded Git.

 

 

Varun Maddula Sep 21, 2017

Hai Jagdish , 

i was a newbieee at using the source tree and bitbucket , followed ur solution it worked perfectly fine .

thanks for the info .

Like Uday Thej Sangineedy likes this
Huy Pham Dec 01, 2017

thanks you

Alan Telford Jun 25, 2018

Updating Embedded Git worked for me after restarting Source Tree, thanks

Camilla Camatta Oct 26, 2018

Thank you so much, it worked like a charm!

michael brodigan Apr 11, 2019

This worked for me in Win 10. I had old version of SourceTree 1.9.13 I uninstalled this version and downloaded 3.1.2. Once I did the Update Embedded Git it worked.

5 votes
The-any-Key Aug 15, 2017

I had the same issue "This is not a valid source path / URL "and it got resolved by updating the Embedded Git of Source Tree. I also got an error when trying to push (third party error ... setup password and username... to many failed password attempts...) and this solved that too.

Steps
Open source tree, Tools -> Options -> Click on Git Tab -> Update Embedded Git.

SANJAY BEEDI Dec 15, 2017

Worked for me.
Thanks

2 votes
Eddie Kumar Jan 15, 2018

For me it was version conflict between the GIT Client & GIT-System-Installation , I ended up using the Embedded GIT (instead of System GIT), which resolved the issue.

 

To do so go to: Tools -> Options -> Git (tab) -> "Use Embedded Git" button.

 

HTH

Aubrey Suba May 27, 2018

Works for me. Thanks.

Syed Asad Ali Sep 19, 2018

This works for me on MAC also. Thanks.

Vu Tran Nov 26, 2018

For me it was the other option, using

 Tools -> Options -> Git (tab) -> "System" button.

Judyll Mark Agan I'm New Here Jun 05, 2019

Tools -> Options -> Git (tab) -> Embedded

and then Tools -> Options -> Git (tab) -> Update Embedded

worked for me.  Thanks a lot!

1 vote

Hey Andrew,

I've filed an issue on JAC here for you: https://jira.atlassian.com/browse/SRCTREEWIN-1316

The problem seems to be that neither the VCS required not being installed / utilised by SourceTree leads to a completely empty error message. We could be more helpful and say that a Git/Hg install couldn't be found with further help on how to set them up (i.e. "Would you like to set Git/Hg up now?") and take them through that process again.

Cheers

Andrew McDonald Dec 11, 2013

Thanks Kieran. Filling in the error box would definitely help - users just need to be prompted to enable the embedded plugins if they've installed but not enabled them.

you probably made a mistake in the password verify your account

1 vote
Romeo Marbella May 28, 2017

After setting everything to Embedded Git. I was still getting the same error, to solve this, I just ran the software as admin. 

sudhan Jul 16, 2017

i am also having same error pls help

1 vote
Andrew R Sep 05, 2018 • edited

For Mac users

Go to application preferences and select the Git tab. Then click reset on all three buttons for Embedded Git, Git-Flow and Git LFS and that should do the trick.

 

Screen Shot 2018-09-05 at 5.34.10 PM.png

0 votes
Jason Worley Atlassian Team Nov 12, 2013
0 votes
tim uy Nov 20, 2013

I just got this issue checking out SourceTree for a collegue (usually just use cmd line git). Kind of an embarrassing way to start things off!

0 votes
Sun Kim May 17, 2017

Try Embedded Git.

My issue was that I had cygwin installed and the path was set so that cygwin binaries would execute first. The invalid path contained `/cydrive/c/` which should tell you why the invalid path occurred. Not sure if SourceTree needs to use explicit paths all throughout when it is not using Embedded Git. 

I'm reluctant to use SourceTree with all the usability issues and bugs, but I must since we have Bitbucket Server as our repository. :(

0 votes

Below steps I followed to fixed the issue.

 

go to -> Tools -> Options -> Network -> Security Protocol Settings -> checked Enable TLS 1.2 option.

 

and retry cloning.

0 votes
Ozan B. Sep 22, 2018

I preffer System Git, so it's always up to date not having a problem like this.

0 votes
Bernard Oreva Nov 07, 2018

Did Git Version - > Update Embedded, but didn't work. To make mine work, I had to do:

Tools -> Network -> Uncheck "Add proxy server configuration to Git/Mercurial". Hope this helps someone.

0 votes
Neeta S Nov 21, 2018

Tools -> option -> Network -> Check "Add proxy server configuration to Git/Mercurial". Hope this helps someone.

Nghiêm Xuân Tứ Mar 14, 2019

thanks you. i clone successfully

0 votes
Jonathan Lloyd Dec 07, 2018

I had this same issue on a Mercurial repository after a password change in Bitbucket, I tried the solutions above, but I was still having issues. 

The solution for me was to first update SourceTree and then update Embedded Mercurial.

  1. Tools > Options > Updates > Check For Updates and Update
  2. Update and Restart
  3. Tools > Options > Mercurial - Under Mercurial Version click Update Embedded, note the update to the Embedded Mercurial version number.  


Suggest an answer

Log in or Sign up to answer
This widget could not be displayed.
This widget could not be displayed.
Community showcase
Published in Bitbucket Pipelines

Building a Bitbucket Pipe as a casual coder

...ipe.sh :  #!/bin/bash source "$(dirname "$0")/common.sh" enable_debug extra_args="" if [[ "${DEBUG}" == "true" ]]; then extra_args="--verbose" fi # mandatory variables R...

3,063 views 1 20
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you