Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Your current database version won't be supported from 7.10.1

Mohamed Damak October 1, 2022

Bitbucket 7.10.1

postgres 11.14.0

Self hosted instance, debian 10.13

Upgrade menu tells me "Your current database version won't be supported"

While it is seen as supported in the troubleshooting menu and in bitbucket documentation.

I've seen similar problems reported with more recent versions (7.17...) , but I don't see any workaround available.

Should I try to force the upgrade via CLI?

Thank you for your help!

 

2 answers

1 vote
Fabio Racobaldo _Herzum_
Community Leader
Community Leader
Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
October 1, 2022

Hi @Mohamed Damak ,

welcome to the Atlassian community!

Postgres 11.14.o should be supported by Bitbucket. There is an open issue https://jira.atlassian.com/browse/BSERV-13089 that probably affects also 7.10.

Currenlty there is no workaround for that, simply ignore that alert.

Hope this helps,

Fabio

Mohamed Damak October 1, 2022

Yes thank you!

Fabio Racobaldo _Herzum_
Community Leader
Community Leader
Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
October 1, 2022

you are welcome @Mohamed Damak 

1 vote
Nic Brough -Adaptavist-
Community Leader
Community Leader
Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
October 1, 2022

No, you should upgrade the database to a supported version while upgrading Bitbucket.

You haven't said whether 7.10 is the current version or the target version of Bitbucket, so we cant check what the documentation says.

Mohamed Damak October 1, 2022

Thank you for your feedback

Version was 7.10.1 // Postgres 11.14

I upgraded successfully to 7.21.5 while ignoring the message.

Everything is working as expected.

Current version after successful upgrade 7.21.5 // postgres 11.14

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
SERVER
TAGS
AUG Leaders

Atlassian Community Events