Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,455,335
Community Members
 
Community Events
175
Community Groups

Why passing tests are output to the pipeline results

Deleted user Apr 08, 2022

Before only the failing tests would display on the output log but recently the passing tests are displayed too. I had hoped it would go away but doesn't seem to be going away and I've not seen a deliberate update to include passing tests or a solution yet to remove these from the log.

1 answer

0 votes
Syahrul Atlassian Team Apr 10, 2022

G'day @[deleted] 

Just to confirm are you talking about Test reporting in Pipelines ? If yes, you are saying it's now showing the pass test output as well on your pipeline build?

Can you grab me a screenshot showing this behavior on the failing test and passing test, make sure to filter out any private information before sharing.

I look forward to hearing from you.

Cheers,
Syahrul

Deleted user Apr 11, 2022

Hey Syahrul,

 

Thanks for the response, yeah that's correct. I'm not sure why its started doing it but its made looking through failures a pain.

 

The failing test does repeat twice if that helps too, one with this output immediately followed with the stack output.11.04.2022_08.42.06_REC.png

11.04.2022_08.40.36_REC.png

Syahrul Atlassian Team Apr 12, 2022

Hi @[deleted] 

Thanks for the update and screenshot.

This is a verbose output of your pipeline build and not the Test reporting pipeline so it's a completely different issue.

I believe this is an issue with your code/test rather than an issue with the pipeline. I would suggest trying this locally following our guide below to see if it's reprorudcible:

Hope this helps.

Cheers,
Syahrul

Deleted user Apr 13, 2022

Hey @Syahrul ,

 

Thanks for sharing those guides. 

 

I tried both the '--logger "junit"' and '--logger 'trx;LogFileName=log.trx'' suggestions but both pipeline output still had all the passing tests in it.

 

I'm unable to run docker locally.

 

Looking back I only had 'dotnet restore, dotnet test' and it only gave me the failures. I only noticed this after chrome latest stable was updated.

 

Heres my current yml file. I'm using a custom image which acts as 'mcr.microsoft.com/dotnet/sdk:5.0' with a chrome browser install

 

13.04.2022_09.44.36_REC.png

Syahrul Atlassian Team Jun 14, 2022

Hey @[deleted] 

Apologize for the delay, do you still having this issue? If yes, please let me know so I can raise a support ticket to further investigate this issue.

Cheers,
Syahrul

Hey,

 

No problem at all. 

 

Yeah I'm still having the issue.

 

Thank you for checking,

Caol

Hey @Caol Hirvonen 

Noted, I have raised a support ticket on behalf of you to continue the investigation.

Cheers,
Syahrul

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events