Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,466,406
Community Members
 
Community Events
176
Community Groups

Why enabling pipelines in a repository requires SSH setup?

Edited

As far as I remember, you are not allowed to enable Bitbucket Pipelines in Cloud unless you enable SSH in Personal Settings. Why is such configuration is required or recommended?

1 answer

1 accepted

1 vote
Answer accepted
Pramodh M Community Leader Jan 22, 2022

Hi @Jensen Louise Lim

There's no setting like that!

Maybe your workspace is enforced to have 2FA in place which is causing this result

Here's a public repo I just tested it out without SSH Key --> Link here

BB1.png

May I know the Bitbucket pipelines you have enabled has some tasks related to SSH Authentication?

Thanks,
Pramodh

Ohh yes, I do enable 2FA. Is that the whole reason? I do not have SSH authentication in my pipelines and its steps.

@Pramodh M But to enable pipelines we still need to enable 2FA, so its related.

Pramodh M Community Leader Jan 22, 2022

Yes, then 2FA is the reason!!

Like Jensen Louise Lim likes this

But why enabling pipelines need 2FA enable thus SSH setup became a requirements.

Pramodh M Community Leader Jan 22, 2022

No @Jensen Louise Lim 

We don't need a 2FA or SSH key to run pipelines!!

We need an SSH key in order to enable 2FA.

Can you please confirm whether you have added the SSH key?

Or try with adding an SSH Key and updating the 2FA setting, then work with repos you have in your workspace and all is working well and confirm once

Pramodh M Community Leader Jan 22, 2022

Maybe your workspace admin has made it required for the repos in your workspace

Try enabling 2FA and then running the pipelines?

My account is the owner and admin, I don't remember making it required in my repo, maybe because they were set to private.

Pramodh M Community Leader Jan 22, 2022

Thanks @Jensen Louise Lim 

Yep, @Theodora Boudale has given the reason in the thread!! This is it.

To prevent abuse from misusing the Pipelines feature, these are some pre-checks that they have implemented.

So go ahead and enable SSH Key, 2FA on your account which makes it secure!!

Let me know if you have need any clarification.

Thanks,
Pramodh

Pramodh M Community Leader Jan 22, 2022

FYI 

I just created a Pipeline in my account with private access, I was able to run it.

May be if you are using the Bitbucket pipelines feature extensively, that is causing it to enable the SSH Keys

Great, many thanks! This is a helpful clarification.

Like Pramodh M likes this

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events