Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,459,886
Community Members
 
Community Events
176
Community Groups

Unable to login with lost 2FA, recovery codes

I have accidentally reset my phone and thus, lost 2FA present on my device. I'm unable to recollect where I might have stored the recovery keys thus, that too, is not available.

I tried retrieving the recovery keys using SSH keys using the following command:
```

ssh git@bitbucket.org recovery_codes

```

But, I ain't getting any recovery keys in it, only an empty response!

I tried with the email recovery link which gets sent in 24hrs, twice but it is leading back to the 2FA modal.

We use the account at the corporate level and the repositories belong to my employer.  Thus, kindly suggest a recovery to the account or a way to retrieve access to all the repositories by using a new bitbucket account?

P.S.: I know the account password for Atlassian as well as Bitbucket and have 2FA codes for the Atlassian account but, not the Bitbucket account.

2 answers

1 accepted

0 votes
Answer accepted
Caroline R Atlassian Team Aug 02, 2021

Hi, @Rahul Soni! Welcome to the community! 

I reviewed your request and, checking your account, I confirmed that you requested the two-step verification recovery and then, after 24 hours, Bitbucket sent you the two-step verification recovery email. As you said you were not able to recover your access using the link that the system sent to you, I went ahead and sent you a new two-step verification recovery email, could you confirm if you received it?

In case you did, could you try to open the link on this email? In case it doesn't work, could you check if your email server doesn't have an internal feature that is used to check if the email is safe? The reason I’m asking this is that the link on this email can be opened just once, so if the server is trying to confirm if the link is safe and open this link, this could explain why the link is not working. 

Please let me know how it goes and feel free to share any additional questions regarding this case.

Kind regards,
Caroline

Hey @Caroline R

I'm much thankful for the mail that you sent for the 2FA recovery, that mail worked absolutely fine. But, the ones triggered through the 2FA modal on clicking "Forgot code?" aren't working.

We have an email feature where a middleware checks the safeness of the link but, the mail you sent also went through this middleware and I was able to use it.

I guess there's some bug wrt to the 2FA modal-based recovery method, I'll suggest that the team should once troubleshoot and debug the same. Anyways, my issue is resolved, much thanks to you! :)

Also, I was unable to retrieve the recovery codes using SSH, can you please throw some light there? (P.S.: This is just for my and the community's understanding)

Caroline R Atlassian Team Aug 04, 2021

Hi, @Rahul Soni

I'm glad to know the email worked, thanks for your confirmation! 

About the recovery codes, unfortunately, this method is currently not working, but we already have an open bug to fix this issue:

If you are not familiar with our Bug Request Policy, you can read more about it here

I've linked this ticket to the bug. Please consider adding yourself as a watcher, this way you get updated as we make progress with this.

Kind regards,
Caroline

Like # people like this

Hi there,

Could you help me as well dear Support because my 2FA app is lost and I am not able to access to our Bitbucket repository, but I can access to my Atlassian account. I do not have the Recovery code unfortunately.

 

Best regards,

Mamitiana.

Caroline R Atlassian Team Sep 06, 2022

Hi, Mamitiana! 

Sorry for taking so long to respond. I see that you managed to disable your Bitbucket 2sv, so I believe everything is resolved, is this correct? 

Kind regards,
Caroline

Hi Caroline,

Yes everything is OK now, when deactivating it, I have to wait for 24hours.

Regards,

Mamitiana

Like Caroline R likes this
Caroline R Atlassian Team Sep 06, 2022

Awesome! Thanks for your confirmation! 

Hello @Caroline R  my issue is exact similar as that of reported by Rahul Soni , the email recovery link which gets sent in 24hrs, twice but it is leading back to the 2FA modal , can you please help me with this.  Same process I had followed 6 months back it went smooth and I could restore my account but now same process is not helping.

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events