Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Unable to connect to bitbucket.org website

Hi all

I'm trying to go to bitbucket.org via Firefox and Chrome and neither allow me to reach the website. This prevents me logging in to see my repos in a browser and I cannot sign into SourceTree as the registration option for BitBucket Cloud tries to get you to sign in via a browser window.

It appears to be a problem with the site's certificate. I've noticed it happening for the last 2 weeks. Previously it worked successfully.

Firefox reports:

"bitbucket.org has a security policy called HTTP Strict Transport Security (HSTS), which means that Firefox can only connect to it securely. You can’t add an exception to visit this site.

The issue is most likely with the web site, and there is nothing you can do to resolve it."

"Web sites prove their identity via certificates. Firefox does not trust bitbucket.org because its certificate issuer is unknown, the certificate is self-signed, or the server is not sending the correct intermediate certificates."

Google Chrome reports:

"Your connection is not private
Attackers might be trying to steal your information from bitbucket.org (for example, passwords, messages, or credit cards). Learn more
NET::ERR_CERT_AUTHORITY_INVALID"

I'm on a Mac, running macOS High Sierra (10.13.6). Firefox v72.01 and Google Chrome v77.0.3865.90.

Any help appreciated.

Thanks

Andre

6 answers

1 accepted

0 votes
Answer accepted

Thank you all for taking the time to suggest answers.

The issue I've been experiencing is happening at work so I think that is playing a role. I have tested access from home on other machines and I am able to access the site. This was using Firefox and Google Chrome on Mac OS and Firefox on Linux (Fedora 31 and Ubuntu 18.04), without having to make any settings changes.

So there is some difference with connecting from the office, which I can understand, even though it had worked previously.

The issue appears to be linked to the site's security certificate.

In the office the certificate is shown by Firefox and Chrome as being issued by Open DNS and the "Cisco Umbrella Root CA" is not trusted, therefore the certficate is not valid.

At home, the browsers all show the certificate issued by DigiCert and therefore trusted - allowing access to the site.

I will settle for not being able to access the site from work, but I thought the certificate issue was worth raising in case it is an issue for others or the website administrators.

Regards, Andre

I can log in bitbucket.org using Firefox.


Please do you mind to double-check if your computer clock working? Sometimes websites get crazy when the computer's clock is incorrectly set.

Are you able to visit other websites?

Regards

I have been having problems getting to a website here as well. I tracked it down

to a script problem I believe the errors I am getting in web console is

TypeError: localStorage is null

you might check your about:config settings and see

what dom.storage.enabled is setto

when i switch the value to true restart the browser the website loads properly.

0 votes
Tyler T Atlassian Team Feb 24, 2020

It sounds like you may have tried to visit the website using http rather than https.

Be sure to use https when accessing the Bitbucket website: https://bitbucket.org/

Hi Tyler, thanks for your response.  I was using https as the response from Firefox states that the site only accepts https:

"bitbucket.org has a security policy called HTTP Strict Transport Security (HSTS), which means that Firefox can only connect to it securely."

Please see my answer below for my further troubleshooting.

Thanks again.

I'm experiencing the same issue on a self-hosted Jira installation running on a Debian/Plesk server with a Let's Encrypt certificate. I can access Jira with Safari, and it shows as secure, but not with Chrome. I get a "Your connection is not private" error and cannot work around it for some reason.

Its happen sometime you can't access a particular website. There are several reasons for example : 

Your internet connection may be disturb

The website you surf is blocked in your region

The website you open my not install secure SSL certificate.

The website you open may be contain malicious codes so that's why chrome and other browsers protect you from it.

Or last one may be website is down due to heavy load of traffic or server problem.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bitbucket

New improvements to user management in Bitbucket Cloud 👥

Hey Community! We’re willing to wager that quite a few of you not only use Bitbucket, but administer it too. Our team is excited to share that we’ll be releasing improvements throughout this month of...

256 views 2 9
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you