Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Stuck in "We couldn't log you in"

Whenever I log in to my dash board (via. start.atlassian) and click on the "BitBucket" app/link, I am always redirected to the BitBucket official home page (bitbucket.org). From there, when I click on "Log In" on the top right, I will always end up with the page "We couldn't log you in".

I have disabled all extensions on my Chrome browser, delete cookies and history from all time. This issue still persists. I have tried this under both normal and incognito mode.

I can replicate this issue in Firefox and Vivaldi.

Using debug console and checking the traffic, I always notice a HTTP 400 response to a GET request: https://bitbucket.org/account/signin/?redirectCount=2&next=%2F.

There is request header content in the request, so I am sure that the refer header is not the issue.

Checking the response header, this seems to be the problem:

script-src 'unsafe-eval' 'strict-dynamic' 'unsafe-inline' 'self' http: https: https://d301sr5gafysq2.cloudfront.net 'nonce-guAybRltnM7z9DeO'; style-src 'self' 'unsafe-inline' https://aui-cdn.atlassian.com https://d301sr5gafysq2.cloudfront.net; report-uri https://web-security-reports.services.atlassian.com/csp-report/bb-website; default-src 'self' 'unsafe-inline' 'unsafe-eval' data: blob: *; connect-src bitbucket.org *.bitbucket.org bb-inf.net *.bb-inf.net id.atlassian.com analytics.atlassian.com as.atlassian.com api-private.stg.atlassian.com api-private.atlassian.com cofs.staging.public.atl-paas.net cofs.prod.public.atl-paas.net intake.opbeat.com api.media.atlassian.com api.segment.io xid.statuspage.io xid.atlassian.com xid.sourcetreeapp.com bam.nr-data.net bam-cell.nr-data.net sentry.io bqlf8qjztdtr.statuspage.io https://d301sr5gafysq2.cloudfront.net; object-src about:; base-uri 'self'

I am pulling my hair out.

3 answers

1 accepted

0 votes
Answer accepted

Hi @Grant Stone ,

Does this issue occur with the Bitbucket Cloud account that has the same email as your community account?

I checked this account in our system and I saw that it was marked as Spam by our spam filter, which I suspect is the reason why you couldn't log in. Our apologies for the inconvenience caused by this.

I went ahead and activated the account, could you please try logging in now and let me know if it works?

Please feel free to let me know if this concerns a Bitbucket Cloud account with an email other than the one of your community account.

Kind regards,
Theodora

@Theodora Boudale   Could this be my problem, as well?    I am not technical, but have deleted cache, cookies, repeatedly - removed all Chrome extensions (uggh), and can log in successfully and use Jira all data, but when I click on Confluence, I get "we couldn't log you in".       Please help me!

@Theodora Boudale Same here, and we are many more: https://community.atlassian.com/t5/Confluence-questions/quot-We-couldn-t-log-you-in-quot/qaq-p/1671277#U1774764

If you're not replying here (before issue is marked as solved) then should each of us open a new issue with more or less the same content?

I can do that, no problem. But it's not too efficient if the cause was the same for everybody (other people started getting issues in April 2021 so there may be a link, but I got the issue in July 2021 so it may have a different cause). Maybe we could open a special thread to gather information from everyone, or give directives on how to inform the dev team you're affected by the issue (in a cleaner way than commenting here), so they can fix all the accounts at once?

If no answer is posted here for 3 days I'll have to open another ticket. I really need access to my design doc for my project, and I can't find my export backup right now...

UPDATE: OK, I managed to log in to my website by opening Firefox in safe mode, logging in, then restarting in normal mode and I'm still logged in. Possibly you can do that in Chrome but you may need to clear the whole cache (on all websites) and/or remove some extensions (I don't know which of them, the only one that could cause troubles is an ad-blocker and it was locally deactivated). More details in the UPDATE section of my comment in the thread mentioned at the top.

Sorry for the inconvenience, and I don't feel the need to open another ticket right now. Although of course, it would be great if there was a way for logging to work again in Chrome after just a Clear cache on single page + Hard reload, but I don't know how much of it you can control...

Hi @Lamar Chastain and @hsandt,

First, my apologies for the late reply and for the issues you've been facing.

I got no notification for your reply @Lamar Chastain , there must have been a glitch in our system, and I was on leave last week so @hsandt I did not see the notification for your reply in time.

If you face an issue that sounds similar to another user's post, I would like to ask that you please create a new question, in the community collection for the affected product.

Please allow me to explain why:

1) This question is created in the Bitbucket collection and the issue was with the user's Bitbucket account being marked as spam. You both mentioned issues logging in to Confluence. I'm not sure if Confluence has a similar filter (I do Bitbucket Cloud support, and my knowledge on Confluence is limited), but your issues will be better addressed if there is a question in the Confluence collection, so users/Community Leaders/Atlassian staff with knowledge on Confluence can assist you.

2) It's best if each user creates a new question with their issue. I realize it may not sound efficient if the root cause is the same, but in order to figure this out, we need to do some troubleshooting. Troubleshooting, asking questions, and getting user feedback from more than one user in a single post can make the post convoluted and confusing for everybody. It's best to have one question per user so they get assistance with their specific issue, and if the root cause turns out to be the same as another user's, that's ok.

3) If you create a new question, it will be visible to other users, Community Leaders, and Atlassian staff as well who may be able to help. Replying to another user's post will notify only users who are watching this specific post, so your message has less visibility.

4) In order to create a new question, please select Products from the menu bar at the top, and then the affected product (e.g. Confluence). Then select Ask the community > Ask a question. On the next page, you should see all licenses for this product you are a part of. Please select the product/license you have an issue with/question about. This won't be publicly visible, but Atlassian staff will be able to see it, and it may help in case it's needed for troubleshooting purposes.

If you have any questions, please feel free to let me know.

Kind regards,
Theodora

Hello @Theodora Boudale , I'm having the same problem, I'm loged in Atlassian home and goes to Bitbucket and shows "We couldn't log you in".
Thank you

Hi @Theodora Boudale ,

Now the account is working as intended.

I can login, and be redirected to my BitBucket repo page after clicking "Log In" button in the BitBucket official home page.

Thank you!

You are are very welcome, I'm glad to have helped!

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bitbucket

📣 Calling Bitbucket Data Center customers to participate in research

Hi everyone, Are you Bitbucket DC customer? If so, we'd love to talk to you! Our team wants to dive deep to understand your long-term plans regarding Bitbucket DC and Atlassian Cloud. Do you plan...

227 views 2 5
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you