Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,293,533
Community Members
 
Community Events
165
Community Groups

SourceTree "Authentication via SSH keys failed"

I followed the directions to setup SSH for Git and everything works perfectly up to there. I can connect to my BitBucket account (returns my username etc).

I then downloaded SourceTree and went to Tools > Create or Import SSH Keys, then Conversions > Import key > Save private key. After saving I open Pageant and try to clone one of the repos. This is when the error appears. I've tried everything to solve this with no luck.

Has anyone run into this problem and found a solution?

6 answers

1 accepted

7 votes
Answer accepted
AgentSmith Atlassian Team Nov 03, 2013

Apparently the bug in the second answer still exists even though it states after 0.9.0.x it shouldn't. I manually added the key directly within Pageant and it works!

Thanks Jason

4 votes
jyo Atlassian Team Nov 03, 2013

Chris,

You may try re-installing Pageant, found here: http://www.chiark.greenend.org.uk/~sgtatham/putty/download.html

This worked. Simple and quick fix. Thanks :)

Here is what i found Go to >Tools>Options>General Tab>put your ssh private key with .ppk extension>then go into system next with battery in widows>click on paegent with blue mark computer and hat>enter you .ppk key >Enter pass>close it

Now You can push or clone project

If this does not goes well try restart oc and sourcetree

This worked. was stumped as I had added the key to the "Pagent" but it was still throwing the same SSH error, if I set up the GitLab account in Sourcetree to use SSH. Adding the key as mentioned fixed this error. 

 

NOTE: The error would not come if the account was setup to use HTTPS.

Like namson0482 likes this

My suggestion is, install PuTTY yourself, instead of relying on the PuTTY agent that SourceTree installs. Not sure why, but it seems like the agent that SourceTree installs lacks a few features.

Once you install the new PuTTY agent, import the .ppk file that you generated (and saved). The file generated by the PuTTY installed by SourceTree uses the old PEM format. When you open the .ppk with the new PuTTY agent, it will ask you to (convert it) and save it as a .ppk recognised by PuTTY.

Enter the passphrase, and you're good to go. Import this new .ppk into Pageant, and you should be able to clone your repositories.

Hope this helps.

All I had to do is restart Pageant

Did you verify that you have successfully added your private keys (*.ppk) in putty.

It was failing for my case as well. But once I have added explicitly it worked for me.

Like Alfgg likes this

thanks man :-)

I had the same problem. I solved it by going to Settings -> Convert All to SSH.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bitbucket

Git push size limits are coming to Bitbucket Cloud starting April 4th, 2022

Beginning on April 4th, we will be implementing push limits. This means that your push cannot be completed if it is over 3.5 GB. If you do attempt to complete a push that is over 3.5 GB, it will fail...

2,096 views 2 9
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you